03f7eddc84f33097e5dd18d56edf1c4267f3a514
[openwrt/svn-archive/archive.git] / toolchain / gcc / Config.in
1 # Choose gcc version.
2
3 choice
4 prompt "GCC compiler Version" if TOOLCHAINOPTS
5 default GCC_VERSION_3_4_6 if LINUX_2_4
6 default GCC_VERSION_4_2_0 if TARGET_magicbox
7 default GCC_VERSION_4_1_2
8 help
9 Select the version of gcc you wish to use.
10
11 config GCC_VERSION_3_4_6
12 bool "gcc 3.4.6"
13
14 config GCC_VERSION_4_1_2
15 depends !LINUX_2_4
16 bool "gcc 4.1.2"
17
18 config GCC_VERSION_4_2_0
19 depends !LINUX_2_4
20 bool "gcc 4.2.0"
21
22 config GCC_VERSION_4_2_1
23 depends !LINUX_2_4
24 bool "gcc 4.2.1"
25
26 config GCC_VERSION_4_2_2
27 depends !LINUX_2_4
28 bool "gcc 4.2.2"
29
30 config GCC_VERSION_4_2_3
31 depends !LINUX_2_4
32 bool "gcc 4.2.3"
33
34 endchoice
35
36 config EXTRA_GCC_CONFIG_OPTIONS
37 string
38 prompt "Additional gcc options" if TOOLCHAINOPTS
39 default ""
40 help
41 Any additional gcc options you may want to include....
42
43 config INSTALL_LIBSTDCPP
44 bool
45 prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
46 default y
47 help
48 Build/install c++ compiler and libstdc++?
49
50 config INSTALL_LIBGCJ
51 bool
52 prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
53 default n
54 help
55 Build/install java compiler and GNU classpath ?