[toolchain/gcc/linaro]: upgrade to 2011.02, rename patchset directory
[openwrt/svn-archive/archive.git] / toolchain / gcc / Config.in
1 # Choose gcc version.
2
3 choice
4 prompt "GCC compiler Version" if TOOLCHAINOPTS
5 default GCC_VERSION_4_3_5 if (avr32 || powerpc64)
6 default GCC_VERSION_4_3_5 if (TARGET_coldfire || TARGET_etrax || TARGET_gemini || TARGET_cns21xx)
7 default GCC_VERSION_4_3_3_CS if (arm || armeb) && !(TARGET_gemini || TARGET_cns21xx || TARGET_omap35xx)
8 default GCC_VERSION_4_3_3_CS if (mips || mipsel) && !(TARGET_octeon || TARGET_sibyte)
9 default GCC_VERSION_4_4_5 if (powerpc || ubicom32)
10 default GCC_VERSION_4_4_5 if (TARGET_omap35xx || TARGET_octeon || TARGET_sibyte)
11 default GCC_VERSION_LINARO
12 help
13 Select the version of gcc you wish to use.
14
15 config GCC_VERSION_4_3_5
16 bool "gcc 4.3.5"
17
18 config GCC_VERSION_4_4_5
19 bool "gcc 4.4.5"
20
21 config GCC_VERSION_4_5_2
22 bool "gcc 4.5.2"
23
24 config GCC_VERSION_LINARO
25 bool "gcc 4.5.2 with Linaro enhancements"
26
27 config GCC_VERSION_LLVM
28 bool "llvm-gcc 4.2"
29 depends BROKEN
30
31 config GCC_VERSION_4_3_3_CS
32 bool "gcc 4.3.3 with CodeSourcery enhancements"
33
34 config GCC_VERSION_4_4_1_CS
35 bool "gcc 4.4.1 with CodeSourcery enhancements"
36
37 endchoice
38
39 config GCC_USE_GRAPHITE
40 bool
41 prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
42 depends GCC_VERSION_4_4 || GCC_VERSION_4_5
43
44 config GCC_USE_SYSTEM_PPL_CLOOG
45 bool
46 prompt "Use the system versions of PPL and CLooG"
47 depends GCC_USE_GRAPHITE
48 default n
49
50 config EXTRA_GCC_CONFIG_OPTIONS
51 string
52 prompt "Additional gcc configure options" if TOOLCHAINOPTS
53 default ""
54 help
55 Any additional gcc options you may want to include....
56
57 config SSP_SUPPORT
58 bool
59 prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
60 default n
61 help
62 Enable Stack-Smashing Protection support
63
64 config TLS_SUPPORT
65 bool
66 depends UCLIBC_VERSION_NPTL
67 prompt "Enable Thread-local storage (TLS) support" if TOOLCHAINOPTS
68 default n
69 help
70 Enable Thread-local storage support
71
72 config INSTALL_LIBSTDCPP
73 bool
74 prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
75 default y
76 help
77 Build/install c++ compiler and libstdc++?
78
79 config INSTALL_LIBGCJ
80 bool
81 depends on !GCC_VERSION_LLVM
82 prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
83 default n
84 help
85 Build/install java compiler and GNU classpath ?