Gcc 4.3.3 default for etrax
[openwrt/svn-archive/archive.git] / toolchain / gcc / Config.in
1 # Choose gcc version.
2
3 choice
4 prompt "GCC compiler Version" if TOOLCHAINOPTS
5 default GCC_VERSION_3_4_6 if LINUX_2_4
6 default GCC_VERSION_4_2_4 if TARGET_avr32
7 default GCC_VERSION_4_2_4 if TARGET_ppc40x
8 default GCC_VERSION_4_2_4 if TARGET_ppc44x
9 default GCC_VERSION_4_3_3 if TARGET_ps3_petitboot
10 default GCC_VERSION_4_3_3 if TARGET_etrax
11 default GCC_VERSION_4_1_2
12 help
13 Select the version of gcc you wish to use.
14
15 config GCC_VERSION_3_4_6
16 bool "gcc 3.4.6"
17
18 if !LINUX_2_4
19 config GCC_VERSION_4_1_2
20 bool "gcc 4.1.2"
21
22 config GCC_VERSION_4_2_4
23 bool "gcc 4.2.4"
24
25 config GCC_VERSION_4_3_3
26 bool "gcc 4.3.3"
27
28 config GCC_VERSION_4_4_0
29 bool "gcc 4.4.0"
30 endif
31
32 endchoice
33
34 config EABI_SUPPORT
35 bool
36 depends arm||armeb
37 prompt "Enable EABI support" if TOOLCHAINOPTS
38 default y
39 help
40 Enable ARM EABI support
41
42 config EXTRA_GCC_CONFIG_OPTIONS
43 string
44 prompt "Additional gcc options" if TOOLCHAINOPTS
45 default ""
46 help
47 Any additional gcc options you may want to include....
48
49 config SSP_SUPPORT
50 bool
51 depends !GCC_VERSION_3_4_6
52 prompt "Enable Smash Stacking Protection support" if TOOLCHAINOPTS
53 default n
54 help
55 Enable Smash Stacking Protection support
56
57 config INSTALL_LIBSTDCPP
58 bool
59 prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
60 default y
61 help
62 Build/install c++ compiler and libstdc++?
63
64 config INSTALL_LIBGCJ
65 bool
66 prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
67 default n
68 help
69 Build/install java compiler and GNU classpath ?