[toolchain]: replace gcc 4.5.2 support with 4.6.1
[openwrt/svn-archive/archive.git] / toolchain / gcc / patches / 4.6.1 / 302-c99-snprintf.patch
1 --- a/libstdc++-v3/include/c_global/cstdio
2 +++ b/libstdc++-v3/include/c_global/cstdio
3 @@ -137,7 +137,7 @@ namespace std
4 using ::vsprintf;
5 } // namespace
6
7 -#if _GLIBCXX_USE_C99
8 +#if _GLIBCXX_USE_C99 || defined __UCLIBC__
9
10 #undef snprintf
11 #undef vfscanf