[toolchain] add support for gcc v4.3.1 & v4.3.2 (closes: #3479), thanks to Luigi...
[openwrt/svn-archive/archive.git] / toolchain / uClibc / patches / 910-gcc_4_3_include_fixed.patch
1 diff -ruN uClibc-0.9.29-old/Rules.mak uClibc-0.9.29-new/Rules.mak
2 --- uClibc-0.9.29-old/Rules.mak 2009-01-17 16:18:36.662982000 +0100
3 +++ uClibc-0.9.29-new/Rules.mak 2009-01-17 19:14:02.473165330 +0100
4 @@ -498,7 +498,8 @@
5
6 # Sigh, some stupid versions of gcc can't seem to cope with '-iwithprefix include'
7 #CFLAGS+=-iwithprefix include
8 -CFLAGS+=-isystem $(shell $(CC) -print-file-name=include)
9 +CC_IPREFIX:=$(shell $(CC) -print-file-name=include)
10 +CFLAGS+=-isystem $(CC_IPREFIX) -isystem $(CC_IPREFIX)-fixed
11
12 ifneq ($(DOASSERTS),y)
13 CFLAGS+=-DNDEBUG