ath9k: disable PA predistortion by default, since it has been reported to reduce...
[openwrt/svn-archive/archive.git] / Config.in
index 3ce7b6b..4035978 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -46,7 +46,6 @@ menu "Target Images"
 
                        config TARGET_INITRAMFS_COMPRESSION_XZ
                                bool "xz"
-                               depends !LINUX_2_6_30&&!LINUX_2_6_31&&!LINUX_2_6_32&&!LINUX_2_6_36&&!LINUX_2_6_37
                endchoice
 
                config EXTERNAL_CPIO
@@ -154,6 +153,13 @@ menu "Global build settings"
                  When this option is enabled, packages are built with the full versions of iconv and GNU gettext
                  instead of the default OpenWrt stubs. If uClibc is used, it is also built with locale support.
 
+       config BUILD_STATIC_TOOLS
+               default n
+               bool "Attempt to link host utilities statically"
+               help
+                 Linking host utilities like sed or firmware-utils statically increases the portability of the
+                 generated ImageBuilder and SDK tarballs, however it may fail on some Linux distributions.
+
        config SHADOW_PASSWORDS
                bool
                prompt "Enable shadow password support"
@@ -318,6 +324,7 @@ menu "Global build settings"
                bool
                prompt "Parallelize the default package build rule (May break build)"
                depends on PKG_BUILD_PARALLEL
+               depends on BROKEN
                default n
                help
                  Always set the default package build rules to parallel build.
@@ -333,6 +340,7 @@ menu "Global build settings"
                bool
                prompt "Parallelize the toolchain build (May break build)"
                depends on PKG_BUILD_PARALLEL
+               depends on BROKEN
                default n
                help
                  Build the toolchain with parallel make jobs.
@@ -396,6 +404,21 @@ menu "Global build settings"
                  Note that this will make the system libraries incompatible with most of the packages
                  that are not selected during the build process
 
+       choice
+               prompt "Preferred standard C++ library"
+               default USE_LIBSTDCXX if USE_EGLIBC
+               default USE_UCLIBCXX
+               help
+                 Select the preferred standard C++ library for all packages that support this.
+
+               config USE_UCLIBCXX
+                       bool "uClibc++"
+
+               config USE_LIBSTDCXX
+                       bool "libstdc++"
+
+       endchoice
+
 endmenu
 
 menuconfig DEVEL