ixp4xx: make apex optional, clean up the makefile - fixes spurious recompilation...
[openwrt/svn-archive/archive.git] / Makefile
index 4bdc4651e82682a8846c144e0356fbe0b40ad306..05a2c2b21b066672762e188d2bced5ac8579945b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -72,7 +72,7 @@ prereq: $(target/stamp-prereq) tmp/.prereq_packages
 
 prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
 world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
-       $(_SINGLE)$(SUBMAKE) package/index
+       $(_SINGLE)$(SUBMAKE) -r package/index
 
 # update all feeds, re-create index files, install symlinks
 package/symlinks: