Make b43 module depend on crypto modules
[openwrt/svn-archive/archive.git] / Makefile
index 970b0896ca80b3ae3548b15cbcdf31da1600e0e6..72b24d14e7c71a952fd57360015e3f2ab2b44e0a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -16,6 +16,12 @@ world:
 include $(TOPDIR)/include/host.mk
 
 ifneq ($(OPENWRT_BUILD),1)
+  # XXX: these three lines are normally defined by rules.mk
+  # but we can't include that file in this context
+  empty:=
+  space:= $(empty) $(empty)
+  _SINGLE=MAKEFLAGS=$(space)
+
   override OPENWRT_BUILD=1
   export OPENWRT_BUILD
   include $(TOPDIR)/include/debug.mk
@@ -44,7 +50,7 @@ $(BUILD_DIR)/.prepared: Makefile
 
 clean: FORCE
        rm -rf $(BUILD_DIR) $(BIN_DIR)
-       $(MAKE) target/linux/clean
+       $(SUBMAKE) target/linux/clean
 
 dirclean: clean
        rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST)
@@ -55,11 +61,22 @@ prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
 
 prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
 world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
-       $(MAKE) package/index
+       $(SUBMAKE) package/index
 
+# update all feeds, re-create index files, install symlinks
 package/symlinks:
-       $(SCRIPT_DIR)/feeds.sh $(CONFIG_SOURCE_FEEDS) $(CONFIG_SOURCE_FEEDS_REV)        
+       $(SCRIPT_DIR)/feeds update -a
+       $(SCRIPT_DIR)/feeds install -a
+
+# re-create index files, install symlinks
+package/symlinks-install:
+       $(SCRIPT_DIR)/feeds update -i
+       $(SCRIPT_DIR)/feeds install -a
+
+# remove all symlinks, don't touch ./feeds
+package/symlinks-clean:
+       $(SCRIPT_DIR)/feeds uninstall -a
 
-.PHONY: clean dirclean prereq prepare world package/symlinks
+.PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean
 
 endif