[x86] grub: Natively build grub only on x86 linux hosts, cross compile everywhere...
[openwrt/svn-archive/archive.git] / Makefile
index b67413b887309808b09a877e39310452d096e565..72b24d14e7c71a952fd57360015e3f2ab2b44e0a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -9,14 +9,19 @@
 TOPDIR:=${CURDIR}
 LC_ALL:=C
 LANG:=C
-IS_TTY:=${shell tty -s && echo 1 || echo 0}
-export TOPDIR LC_ALL LANG IS_TTY
+export TOPDIR LC_ALL LANG
 
 world:
 
 include $(TOPDIR)/include/host.mk
 
 ifneq ($(OPENWRT_BUILD),1)
+  # XXX: these three lines are normally defined by rules.mk
+  # but we can't include that file in this context
+  empty:=
+  space:= $(empty) $(empty)
+  _SINGLE=MAKEFLAGS=$(space)
+
   override OPENWRT_BUILD=1
   export OPENWRT_BUILD
   include $(TOPDIR)/include/debug.mk
@@ -31,10 +36,13 @@ else
   include tools/Makefile
   include toolchain/Makefile
 
-$(toolchain/stamp-compile): $(tools/stamp-compile)
+$(toolchain/stamp-install): $(tools/stamp-install)
 $(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
-$(package/stamp-compile): $(target/stamp-compile)
-$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
+$(package/stamp-cleanup): $(target/stamp-compile)
+$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
+$(package/stamp-install): $(package/stamp-compile)
+$(package/stamp-rootfs-prepare): $(package/stamp-install)
+$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare)
 
 $(BUILD_DIR)/.prepared: Makefile
        @mkdir -p $$(dirname $@)
@@ -42,22 +50,33 @@ $(BUILD_DIR)/.prepared: Makefile
 
 clean: FORCE
        rm -rf $(BUILD_DIR) $(BIN_DIR)
-       $(MAKE) target/linux/clean
-       rm -rf $(TMP_DIR)
+       $(SUBMAKE) target/linux/clean
 
 dirclean: clean
        rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST)
+       rm -rf $(TMP_DIR)
 
 # check prerequisites before starting to build
 prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
 
 prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
 world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
-       $(MAKE) package/index
+       $(SUBMAKE) package/index
 
+# update all feeds, re-create index files, install symlinks
 package/symlinks:
-       $(SCRIPT_DIR)/feeds.sh $(CONFIG_SOURCE_FEEDS) $(CONFIG_SOURCE_FEEDS_REV)        
+       $(SCRIPT_DIR)/feeds update -a
+       $(SCRIPT_DIR)/feeds install -a
+
+# re-create index files, install symlinks
+package/symlinks-install:
+       $(SCRIPT_DIR)/feeds update -i
+       $(SCRIPT_DIR)/feeds install -a
+
+# remove all symlinks, don't touch ./feeds
+package/symlinks-clean:
+       $(SCRIPT_DIR)/feeds uninstall -a
 
-.PHONY: clean dirclean prereq prepare world package/symlinks
+.PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean
 
 endif