[kernel] netfilter: fix compiler warnings in xt_layer7
[openwrt/svn-archive/archive.git] / Makefile
index b67413b887309808b09a877e39310452d096e565..77660bb8d7e11ed8d8dababd146ea6759a1bcce9 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -9,8 +9,7 @@
 TOPDIR:=${CURDIR}
 LC_ALL:=C
 LANG:=C
-IS_TTY:=${shell tty -s && echo 1 || echo 0}
-export TOPDIR LC_ALL LANG IS_TTY
+export TOPDIR LC_ALL LANG
 
 world:
 
@@ -31,10 +30,13 @@ else
   include tools/Makefile
   include toolchain/Makefile
 
-$(toolchain/stamp-compile): $(tools/stamp-compile)
+$(toolchain/stamp-install): $(tools/stamp-install)
 $(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
-$(package/stamp-compile): $(target/stamp-compile)
-$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
+$(package/stamp-cleanup): $(target/stamp-compile)
+$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
+$(package/stamp-install): $(package/stamp-compile)
+$(package/stamp-rootfs-prepare): $(package/stamp-install)
+$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare)
 
 $(BUILD_DIR)/.prepared: Makefile
        @mkdir -p $$(dirname $@)
@@ -43,10 +45,10 @@ $(BUILD_DIR)/.prepared: Makefile
 clean: FORCE
        rm -rf $(BUILD_DIR) $(BIN_DIR)
        $(MAKE) target/linux/clean
-       rm -rf $(TMP_DIR)
 
 dirclean: clean
        rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST)
+       rm -rf $(TMP_DIR)
 
 # check prerequisites before starting to build
 prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
@@ -56,7 +58,8 @@ world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-
        $(MAKE) package/index
 
 package/symlinks:
-       $(SCRIPT_DIR)/feeds.sh $(CONFIG_SOURCE_FEEDS) $(CONFIG_SOURCE_FEEDS_REV)        
+       $(SCRIPT_DIR)/feeds update
+       cd package; ln -sf ../feeds/packages openwrt-packages
 
 .PHONY: clean dirclean prereq prepare world package/symlinks