[tools] firmware-utils:fix a bug in mkzynfw, thanks to <theosch at gmx.de> (closes...
[openwrt/svn-archive/archive.git] / Makefile
index fbed1297a1eb6c8fd915a0afc3579504af563bc6..77660bb8d7e11ed8d8dababd146ea6759a1bcce9 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -9,61 +9,58 @@
 TOPDIR:=${CURDIR}
 LC_ALL:=C
 LANG:=C
-IS_TTY:=${shell tty -s && echo 1 || echo 0}
-export TOPDIR LC_ALL LANG IS_TTY
+export TOPDIR LC_ALL LANG
 
 world:
 
-include $(TOPDIR)/include/debug.mk
 include $(TOPDIR)/include/host.mk
 
 ifneq ($(OPENWRT_BUILD),1)
   override OPENWRT_BUILD=1
   export OPENWRT_BUILD
+  include $(TOPDIR)/include/debug.mk
+  include $(TOPDIR)/include/depends.mk
   include $(TOPDIR)/include/toplevel.mk
 else
   include rules.mk
   include $(INCLUDE_DIR)/depends.mk
   include $(INCLUDE_DIR)/subdir.mk
+  include target/Makefile
   include package/Makefile
   include tools/Makefile
   include toolchain/Makefile
 
-clean: FORCE
-       rm -rf build_* bin tmp
+$(toolchain/stamp-install): $(tools/stamp-install)
+$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
+$(package/stamp-cleanup): $(target/stamp-compile)
+$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
+$(package/stamp-install): $(package/stamp-compile)
+$(package/stamp-rootfs-prepare): $(package/stamp-install)
+$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare)
 
-dirclean: clean
-       rm -rf staging_dir_* toolchain_build_* tool_build
+$(BUILD_DIR)/.prepared: Makefile
+       @mkdir -p $$(dirname $@)
+       @touch $@
 
-distclean: dirclean config-clean symlinkclean docs/clean
-       rm -rf dl
+clean: FORCE
+       rm -rf $(BUILD_DIR) $(BIN_DIR)
+       $(MAKE) target/linux/clean
 
-target/%: FORCE
-       $(MAKE) -C $(patsubst %/$*,%,$@) $*
+dirclean: clean
+       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST)
+       rm -rf $(TMP_DIR)
 
 # check prerequisites before starting to build
-prereq: tmp/.prereq-target $(package/stamp-prereq) ;
+prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
 
-world: .config $(tools/stamp-install) $(toolchain/stamp-install) FORCE
-       $(MAKE) target/compile
-       $(MAKE) package/compile
-       $(MAKE) package/install
-       $(MAKE) target/install
+prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
+world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
        $(MAKE) package/index
 
 package/symlinks:
-       $(SCRIPT_DIR)/feeds.sh $(CONFIG_SOURCE_FEEDS) $(CONFIG_SOURCE_FEEDS_REV)        
+       $(SCRIPT_DIR)/feeds update
+       cd package; ln -sf ../feeds/packages openwrt-packages
 
-# FIXME: remove after converting target/ to new structure
-tmp/.prereq-target: tmp/.targetinfo .config
-tmp/.prereq-target: include/prereq.mk 
-       mkdir -p tmp
-       rm -f tmp/.host.mk
-       @+$(NO_TRACE_MAKE) -s -C target prereq 2>/dev/null || { \
-               echo "Prerequisite check failed. Use FORCE=1 to override."; \
-               false; \
-       }
-       touch $@
-.SILENT: tmp/.prereq-target
+.PHONY: clean dirclean prereq prepare world package/symlinks
 
 endif