add compatibility patch for d80211
[openwrt/svn-archive/archive.git] / Makefile
index d6b1b7d61854d1118c55e4c08fd52a94353012f1..8bd0bc710aed9a2b4d11c01eb84d5e49b961db1d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -20,11 +20,13 @@ all: world
 SHELL:=/usr/bin/env bash
 export LC_ALL=C
 export LANG=C
-export TOPDIR=${shell pwd}
-include $(TOPDIR)/include/verbose.mk
+export TOPDIR=${CURDIR}
 ifeq ($(KBUILD_VERBOSE),99)
   MAKE:=3>/dev/null $(MAKE)
 endif
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
+
+include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
@@ -37,37 +39,44 @@ else
 endif
 export OPENWRTVERSION
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts Makefile),tmp/.pkginfo)
+ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts include),tmp/.pkginfo)
   tmp/.pkginfo: FORCE
 endif
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts Makefile),tmp/.targetinfo)
+ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts include),tmp/.targetinfo)
   tmp/.targetinfo: FORCE
 endif
 
 ifeq ($(FORCE),)
   .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
-  world: tmp/.prereq-packages
+  world: tmp/.prereq-packages tmp/.prereq-target
 endif
 
-tmp/.pkginfo:
+ifeq ($(IS_TTY),1)
+  define progress
+       printf "\033[M\r$(1)" >&2;
+  endef
+endif
+
+define dumpinfo
        @mkdir -p tmp
-       @echo Collecting package info...
-       @-for dir in package/*/; do \
+       @echo -n Collecting $(2) info... 
+       @-for dir in $(1)/*/; do \
                [ -f "$${dir}/Makefile" ] || continue; \
+               $(call progress,Collecting $(2) info: $${dir%%/}) \
                echo Source-Makefile: $${dir}Makefile; \
                $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
                echo; \
        done > $@
+       @($(call progress,Collecting $(2) info: done))
+       @echo
+endef
+
+tmp/.pkginfo:
+       $(call dumpinfo,package,package)
 
 tmp/.targetinfo:
-       @mkdir -p tmp
-       @echo Collecting target info...
-       @-for dir in target/linux/*/; do \
-               [ -f "$${dir}/Makefile" ] || continue; \
-               ( cd "$$dir"; $(NO_TRACE_MAKE) --no-print-dir DUMP=1 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2 ); \
-               echo; \
-       done > $@
+       $(call dumpinfo,target/linux,target)
 
 tmpinfo-clean: FORCE
        @-rm -rf tmp/.pkginfo tmp/.targetinfo
@@ -118,6 +127,7 @@ toolchain/%: tmp/.targetinfo FORCE
 
 tmp/.prereq-build: include/prereq-build.mk
        @mkdir -p tmp
+       @rm -f tmp/.host.mk
        @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
                echo "Prerequisite check failed. Use FORCE=1 to override."; \
                false; \
@@ -126,13 +136,23 @@ tmp/.prereq-build: include/prereq-build.mk
 
 tmp/.prereq-packages: include/prereq.mk tmp/.pkginfo .config
        @mkdir -p tmp
+       @rm -f tmp/.host.mk
        @$(NO_TRACE_MAKE) -s -C package prereq 2>/dev/null || { \
                echo "Prerequisite check failed. Use FORCE=1 to override."; \
                false; \
        }
        @touch $@
-       
-prereq: tmp/.prereq-build tmp/.prereq-packages FORCE
+
+tmp/.prereq-target: include/prereq.mk tmp/.targetinfo .config
+       @mkdir -p tmp
+       @rm -f tmp/.host.mk
+       @$(NO_TRACE_MAKE) -s -C target prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+
+prereq: tmp/.prereq-build tmp/.prereq-packages tmp/.prereq-target FORCE
 
 download: .config FORCE
        $(MAKE) tools/download
@@ -158,7 +178,10 @@ dirclean: clean
 distclean: dirclean config-clean
        rm -rf dl
 
+help:
+       cat README
+
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;
-.PHONY: FORCE
+.PHONY: FORCE help
 %: ;