add compatibility patch for d80211
[openwrt/svn-archive/archive.git] / Makefile
index e97423ee631d60806b98931e2c7d114b4cf50233..8bd0bc710aed9a2b4d11c01eb84d5e49b961db1d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -52,24 +52,31 @@ ifeq ($(FORCE),)
   world: tmp/.prereq-packages tmp/.prereq-target
 endif
 
-tmp/.pkginfo:
+ifeq ($(IS_TTY),1)
+  define progress
+       printf "\033[M\r$(1)" >&2;
+  endef
+endif
+
+define dumpinfo
        @mkdir -p tmp
-       @echo Collecting package info...
-       @-for dir in package/*/; do \
+       @echo -n Collecting $(2) info... 
+       @-for dir in $(1)/*/; do \
                [ -f "$${dir}/Makefile" ] || continue; \
+               $(call progress,Collecting $(2) info: $${dir%%/}) \
                echo Source-Makefile: $${dir}Makefile; \
                $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
                echo; \
        done > $@
+       @($(call progress,Collecting $(2) info: done))
+       @echo
+endef
+
+tmp/.pkginfo:
+       $(call dumpinfo,package,package)
 
 tmp/.targetinfo:
-       @mkdir -p tmp
-       @echo Collecting target info...
-       @-for dir in target/linux/*/; do \
-               [ -f "$${dir}/Makefile" ] || continue; \
-               ( cd "$$dir"; $(NO_TRACE_MAKE) --no-print-dir DUMP=1 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2 ); \
-               echo; \
-       done > $@
+       $(call dumpinfo,target/linux,target)
 
 tmpinfo-clean: FORCE
        @-rm -rf tmp/.pkginfo tmp/.targetinfo
@@ -171,7 +178,10 @@ dirclean: clean
 distclean: dirclean config-clean
        rm -rf dl
 
+help:
+       cat README
+
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;
-.PHONY: FORCE
+.PHONY: FORCE help
 %: ;