toolchain/musl: add support for 0.9.9
[openwrt/svn-archive/archive.git] / Makefile
index 348e64500592d502b100ec2e5cb9fe96d6534f2d..9197640b3678e7d168c4338dffe4808ec5722941 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,6 +11,10 @@ LC_ALL:=C
 LANG:=C
 export TOPDIR LC_ALL LANG
 
+empty:=
+space:= $(empty) $(empty)
+$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
+
 world:
 
 include $(TOPDIR)/include/host.mk
@@ -50,7 +54,6 @@ printdb:
 prepare: $(target/stamp-compile)
 
 clean: FORCE
-       $(_SINGLE)$(SUBMAKE) target/linux/clean
        rm -rf $(BUILD_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)
 
 dirclean: clean