Add a doc target and use the defined source feeds to make symlinks
[openwrt/svn-archive/archive.git] / Makefile
index daadbeacf65a7bb4ecd22f745ef4a3d828dfcbaf..a3d5720db3b2b0eb7df3e8658c4c77e801da6d70 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -181,8 +181,14 @@ distclean: dirclean config-clean
 help:
        cat README
 
+doc:
+       $(MAKE) -C docs/ openwrt.pdf
+
+docclean:
+       $(MAKE) -C docs/ clean
+
 symlinks:
-       scripts/feeds.sh https://svn.openwrt.org/openwrt/packages
+       scripts/feeds.sh $(CONFIG_SOURCE_FEEDS) 
 
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;