remove uneeded PATH setting in ipkg invocation
[openwrt/svn-archive/archive.git] / Makefile
index 8a052674b4d5c9b14d64b688532dd341a78d7f93..a5e03d1cb3c48fc09ecc3ff3b43da4bf345f5fb9 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -14,41 +14,43 @@ export TOPDIR LC_ALL LANG IS_TTY
 
 world:
 
-include $(TOPDIR)/include/debug.mk
 include $(TOPDIR)/include/host.mk
 
 ifneq ($(OPENWRT_BUILD),1)
   override OPENWRT_BUILD=1
   export OPENWRT_BUILD
+  include $(TOPDIR)/include/debug.mk
   include $(TOPDIR)/include/toplevel.mk
 else
   include rules.mk
   include $(INCLUDE_DIR)/depends.mk
   include $(INCLUDE_DIR)/subdir.mk
-  include $(INCLUDE_DIR)/target.mk
   include target/Makefile
   include package/Makefile
   include tools/Makefile
   include toolchain/Makefile
 
 $(toolchain/stamp-compile): $(tools/stamp-compile)
-$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install)
+$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
 $(package/stamp-compile): $(target/stamp-compile)
 $(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
 
+$(BUILD_DIR)/.prepared: Makefile
+       @mkdir -p $$(dirname $@)
+       @touch $@
+
 clean: FORCE
-       rm -rf build_* bin tmp
+       rm -rf $(BUILD_DIR) $(BIN_DIR)
+       $(MAKE) target/linux/clean
+       rm -rf $(TMP_DIR)
 
 dirclean: clean
-       rm -rf staging_dir_* toolchain_build_* tool_build
-
-distclean: dirclean 
-       rm -rf dl .config*
+       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(BUILD_DIR_TOOLCHAIN) $(BUILD_DIR_HOST)
 
 # check prerequisites before starting to build
 prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
 
-world: .config $(tools/stamp-install) $(toolchain/stamp-install) $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
+world: .config $(tools/stamp-install) $(toolchain/stamp-install) $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
        $(MAKE) package/index
 
 package/symlinks: