disable filterwin2k in dnsmasq (see #2566)
[openwrt/svn-archive/archive.git] / Makefile
index 48a138db15e05a6b724d0162b42623d2fd18bdca..b67413b887309808b09a877e39310452d096e565 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -20,6 +20,7 @@ ifneq ($(OPENWRT_BUILD),1)
   override OPENWRT_BUILD=1
   export OPENWRT_BUILD
   include $(TOPDIR)/include/debug.mk
+  include $(TOPDIR)/include/depends.mk
   include $(TOPDIR)/include/toplevel.mk
 else
   include rules.mk
@@ -50,10 +51,13 @@ dirclean: clean
 # check prerequisites before starting to build
 prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
 
-world: .config $(tools/stamp-install) $(toolchain/stamp-install) $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
+prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
+world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
        $(MAKE) package/index
 
 package/symlinks:
        $(SCRIPT_DIR)/feeds.sh $(CONFIG_SOURCE_FEEDS) $(CONFIG_SOURCE_FEEDS_REV)        
 
+.PHONY: clean dirclean prereq prepare world package/symlinks
+
 endif