same as [6881]
[openwrt/svn-archive/archive.git] / Makefile
index 43ed005b8ade32dafec91c54d1693c839a7fbfe3..cab2486fb162c027a84f4e1d5329933bdc62c3e0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -62,10 +62,10 @@ tmp/.config-%.in: tmp/.%info
 
 
 .config: ./scripts/config/conf tmp/.config-target.in tmp/.config-package.in
-       @[ -f .config ] || { \
-               [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
+       @if [ \! -f .config -a -e $(HOME)/.openwrt/defconfig ]; then \ 
+               cp $(HOME)/.openwrt/defconfig .config; \
                $(NO_TRACE_MAKE) menuconfig; \
-       }
+       fi
        @$< -D .config Config.in &> /dev/null
 
 scripts/config/mconf:
@@ -90,8 +90,9 @@ oldconfig: scripts/config/conf tmp/.config-target.in tmp/.config-package.in FORC
        $< -o Config.in
 
 menuconfig: scripts/config/mconf tmp/.config-target.in tmp/.config-package.in FORCE
-       @[ -f .config ] || \
-               [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config
+       @if [ \! -f .config -a -e $(HOME)/.openwrt/defconfig ]; then \
+               cp $(HOME)/.openwrt/defconfig .config; \
+       fi
        $< Config.in
 
 kernel_menuconfig: .config FORCE