fixes for a few build errors on osx without fink
[openwrt/svn-archive/archive.git] / Makefile
index fffc3bf5dab101e2cee4ed0d8d98d5daeda5164d..d2be7bb61f1cb9747552c1481528d4e1887da373 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -21,9 +21,6 @@ SHELL:=/usr/bin/env bash
 export LC_ALL=C
 export LANG=C
 export TOPDIR=${CURDIR}
-ifeq ($(KBUILD_VERBOSE),99)
-  MAKE:=3>/dev/null $(MAKE)
-endif
 export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 
 include $(TOPDIR)/include/verbose.mk
@@ -47,32 +44,30 @@ endif
 package/%/Makefile: ;
 target/%/Makefile: ;
 
-tmp/.packageinfo: $(wildcard package/*/Makefile include/package*.mk include/kernel.mk) 
-tmp/.targetinfo: $(wildcard target/*/Makefile include/kernel*.mk)
+tmp/.packageinfo: $(wildcard package/*/Makefile include/package*.mk include/kernel.mk) FORCE
+tmp/.targetinfo: $(wildcard target/*/Makefile include/kernel*.mk)  FORCE
 tmp/.%info:
-       @mkdir -p tmp/info
-       @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="$*info" SCAN_DIR="$(patsubst target,target/linux,$*)" SCAN_NAME="$*" SCAN_DEPS="$^" SCAN_EXTRA=""
+       mkdir -p tmp/info
+       $(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="$*info" SCAN_DIR="$(patsubst target,target/linux,$*)" SCAN_NAME="$*" SCAN_DEPS="$(filter-out FORCE, $^)" SCAN_EXTRA=""
 
 tmpinfo-clean: FORCE
-       @-rm -rf tmp/.*info
+       -rm -rf tmp/.*info
 
 tmp/.config-%.in: tmp/.%info
-       @./scripts/metadata.pl $*_config < $< > $@ || rm -f $@
-
-
+       ./scripts/metadata.pl $*_config < $< > $@ || rm -f $@
 
 .config: ./scripts/config/conf tmp/.config-target.in tmp/.config-package.in
-       @[ -f .config ] || { \
+       if [ \! -f .config ]; then \
                [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
                $(NO_TRACE_MAKE) menuconfig; \
-       }
-       @$< -D .config Config.in &> /dev/null
+       fi
+       $< -D .config Config.in &> /dev/null
 
 scripts/config/mconf:
-       @$(MAKE) -C scripts/config all
+       $(MAKE) -C scripts/config all
 
 scripts/config/conf:
-       @$(MAKE) -C scripts/config conf
+       $(MAKE) -C scripts/config conf
 
 
 
@@ -90,9 +85,9 @@ oldconfig: scripts/config/conf tmp/.config-target.in tmp/.config-package.in FORC
        $< -o Config.in
 
 menuconfig: scripts/config/mconf tmp/.config-target.in tmp/.config-package.in FORCE
-       @[ -f .config ] || { \
-               [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
-       }
+       if [ \! -f .config -a -e $(HOME)/.openwrt/defconfig ]; then \
+               cp $(HOME)/.openwrt/defconfig .config; \
+       fi
        $< Config.in
 
 kernel_menuconfig: .config FORCE
@@ -107,22 +102,22 @@ package/% target/% tools/% toolchain/%: FORCE
 
 
 tmp/.prereq-build: include/prereq-build.mk
-       @mkdir -p tmp
-       @rm -f tmp/.host.mk
-       @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
+       mkdir -p tmp
+       rm -f tmp/.host.mk
+       $(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
                echo "Prerequisite check failed. Use FORCE=1 to override."; \
                false; \
        }
-       @touch $@
+       touch $@
 
 tmp/.prereq-%: include/prereq.mk tmp/.%info .config
-       @mkdir -p tmp
-       @rm -f tmp/.host.mk
-       @$(NO_TRACE_MAKE) -s -C $* prereq 2>/dev/null || { \
+       mkdir -p tmp
+       rm -f tmp/.host.mk
+       $(NO_TRACE_MAKE) -s -C $* prereq 2>/dev/null || { \
                echo "Prerequisite check failed. Use FORCE=1 to override."; \
                false; \
        }
-       @touch $@
+       touch $@
 
 prereq: tmp/.prereq-build tmp/.prereq-package tmp/.prereq-target FORCE
 
@@ -160,8 +155,8 @@ docclean:
        $(MAKE) -C docs/ clean
 
 symlinkclean:
-       find package -type l -exec rm -f {} +
+       -find package -type l | xargs rm -f
 
-.SILENT: clean dirclean distclean symlinkclean config-clean download world help
+.SILENT: clean dirclean distclean symlinkclean config-clean download world help tmp/.packageinfo tmp/.targetinfo tmpinfo-clean tmp/.config-package.in tmp/.config-target.in .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package tmp/.prereq-target
 FORCE: ;
 .PHONY: FORCE help