[au1000] switch to 2.6.30.1
[openwrt/svn-archive/archive.git] / Makefile
index a039c9880b41e736106179974aba11f32aa99bda..db79274c9af0e2f1b9666841a780fb5bc154854f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -6,43 +6,90 @@
 # See /LICENSE for more information.
 #
 
-all: world
-
 TOPDIR:=${CURDIR}
 LC_ALL:=C
 LANG:=C
-IS_TTY:=${shell tty -s && echo 1 || echo 0}
-export TOPDIR LC_ALL LANG IS_TTY
+export TOPDIR LC_ALL LANG
+
+world:
+
+include $(TOPDIR)/include/host.mk
 
 ifneq ($(OPENWRT_BUILD),1)
-  export OPENWRT_BUILD:=1
+  # XXX: these three lines are normally defined by rules.mk
+  # but we can't include that file in this context
+  empty:=
+  space:= $(empty) $(empty)
+  _SINGLE=export MAKEFLAGS=$(space);
+
+  override OPENWRT_BUILD=1
+  export OPENWRT_BUILD
+  include $(TOPDIR)/include/debug.mk
+  include $(TOPDIR)/include/depends.mk
   include $(TOPDIR)/include/toplevel.mk
 else
-  include $(TOPDIR)/include/host.mk
-
   include rules.mk
   include $(INCLUDE_DIR)/depends.mk
   include $(INCLUDE_DIR)/subdir.mk
+  include target/Makefile
+  include package/Makefile
   include tools/Makefile
   include toolchain/Makefile
 
+$(toolchain/stamp-install): $(tools/stamp-install)
+$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
+$(package/stamp-cleanup): $(target/stamp-compile)
+$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
+$(package/stamp-install): $(package/stamp-compile)
+$(package/stamp-rootfs-prepare): $(package/stamp-install)
+$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare)
+
+$(BUILD_DIR)/.prepared: Makefile
+       @mkdir -p $$(dirname $@)
+       @touch $@
+
+prepare: $(target/stamp-compile)
+
 clean: FORCE
-       rm -rf build_* bin tmp
+       $(_SINGLE)$(SUBMAKE) target/linux/clean
+       rm -rf $(BUILD_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)
 
 dirclean: clean
-       rm -rf staging_dir_* toolchain_build_* tool_build
+       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST) $(BUILD_DIR_TOOLCHAIN)
+       rm -rf $(TMP_DIR)
+
+tmp/.prereq_packages: .config
+       unset ERROR; \
+       for package in $(sort $(prereq-y) $(prereq-m)); do \
+               $(_SINGLE)$(NO_TRACE_MAKE) -s -r -C package/$$package prereq || ERROR=1; \
+       done; \
+       if [ -n "$$ERROR" ]; then \
+               echo "Package prerequisite check failed."; \
+               false; \
+       fi
+       touch $@
+
+# check prerequisites before starting to build
+prereq: $(target/stamp-prereq) tmp/.prereq_packages
+
+prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
+world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
+       $(_SINGLE)$(SUBMAKE) -r package/index
+
+# update all feeds, re-create index files, install symlinks
+package/symlinks:
+       $(SCRIPT_DIR)/feeds update -a
+       $(SCRIPT_DIR)/feeds install -a
 
-distclean: dirclean config-clean symlinkclean docs/clean
-       rm -rf dl
+# re-create index files, install symlinks
+package/symlinks-install:
+       $(SCRIPT_DIR)/feeds update -i
+       $(SCRIPT_DIR)/feeds install -a
 
-toolchain/% package/% target/%: FORCE
-       $(MAKE) -C $(patsubst %/$*,%,$@) $*
+# remove all symlinks, don't touch ./feeds
+package/symlinks-clean:
+       $(SCRIPT_DIR)/feeds uninstall -a
 
-world: .config $(tools/stamp) $(toolchain/stamp) FORCE
-       $(MAKE) target/compile
-       $(MAKE) package/compile
-       $(MAKE) package/install
-       $(MAKE) target/install
-       $(MAKE) package/index
+.PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean
 
 endif