Added patch from http://www.opensubscriber.com/message/jgarzik@pobox.com/7495139...
[openwrt/svn-archive/archive.git] / Makefile
index 840c28ff61da0c2ba6fe69cfc270d700f52c9bb8..dcd5bae72ef88708ce59690c8fdb8365d0f1080f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -14,12 +14,12 @@ export TOPDIR LC_ALL LANG IS_TTY
 
 world:
 
-include $(TOPDIR)/include/debug.mk
 include $(TOPDIR)/include/host.mk
 
 ifneq ($(OPENWRT_BUILD),1)
   override OPENWRT_BUILD=1
   export OPENWRT_BUILD
+  include $(TOPDIR)/include/debug.mk
   include $(TOPDIR)/include/toplevel.mk
 else
   include rules.mk
@@ -45,15 +45,18 @@ clean: FORCE
        rm -rf $(TMP_DIR)
 
 dirclean: clean
-       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(BUILD_DIR_TOOLCHAIN) $(BUILD_DIR_HOST)
+       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST)
 
 # check prerequisites before starting to build
 prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
 
-world: .config $(tools/stamp-install) $(toolchain/stamp-install) $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
+prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
+world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
        $(MAKE) package/index
 
 package/symlinks:
        $(SCRIPT_DIR)/feeds.sh $(CONFIG_SOURCE_FEEDS) $(CONFIG_SOURCE_FEEDS_REV)        
 
+.PHONY: clean dirclean prereq prepare world package/symlinks
+
 endif