only enable in-tree kmod-* packages by default
[openwrt/svn-archive/archive.git] / Makefile
index 4947cbf954e45c5f6b222eddd1fc706d36d4f41f..eed9335a5be66ba6f5d657f9d775d49f4f7bd6cf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -21,10 +21,12 @@ SHELL:=/usr/bin/env bash
 export LC_ALL=C
 export LANG=C
 export TOPDIR=${shell pwd}
-include $(TOPDIR)/include/verbose.mk
 ifeq ($(KBUILD_VERBOSE),99)
   MAKE:=3>/dev/null $(MAKE)
 endif
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
+
+include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
@@ -37,12 +39,12 @@ else
 endif
 export OPENWRTVERSION
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts Makefile),tmp/.pkginfo)
-  tmp/.pkginfo: tmpinfo-clean
+ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts include),tmp/.pkginfo)
+  tmp/.pkginfo: FORCE
 endif
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts Makefile),tmp/.targetinfo)
-  tmp/.targetinfo: tmpinfo-clean
+ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts include),tmp/.targetinfo)
+  tmp/.targetinfo: FORCE
 endif
 
 ifeq ($(FORCE),)