only enable in-tree kmod-* packages by default
[openwrt/svn-archive/archive.git] / Makefile
index 62a03387463aed51e47d3c46ccb9d19928d799df..eed9335a5be66ba6f5d657f9d775d49f4f7bd6cf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -24,10 +24,7 @@ export TOPDIR=${shell pwd}
 ifeq ($(KBUILD_VERBOSE),99)
   MAKE:=3>/dev/null $(MAKE)
 endif
-ifneq ($(shell tty -s <&3 || echo x),x)
-  IS_TTY=1
-  export IS_TTY
-endif
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 
 include $(TOPDIR)/include/verbose.mk
 
@@ -42,11 +39,11 @@ else
 endif
 export OPENWRTVERSION
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts Makefile),tmp/.pkginfo)
+ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts include),tmp/.pkginfo)
   tmp/.pkginfo: FORCE
 endif
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts Makefile),tmp/.targetinfo)
+ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts include),tmp/.targetinfo)
   tmp/.targetinfo: FORCE
 endif