revert to the previous version of the flash map driver - committed the wrong one...
[openwrt/svn-archive/archive.git] / Makefile
index 2a5180c61bf07a27bf63249caaf76a320f317188..f06b151eb28e2b35c54610457513cea6560f6a64 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -53,7 +53,7 @@ tmp/.%info:
 tmpinfo-clean: FORCE
        -rm -rf tmp/.*info
 
-tmp/.config-%.in: tmp/.%info
+tmp/.config-%.in: tmp/.%info scripts/metadata.pl
        ./scripts/metadata.pl $*_config < $< > $@ || rm -f $@
 
 .config: ./scripts/config/conf tmp/.config-target.in tmp/.config-package.in
@@ -155,7 +155,7 @@ docclean:
        $(MAKE) -C docs/ clean
 
 symlinkclean:
-       find package -type l -exec rm -f {} +
+       -find package -type l | xargs rm -f
 
 .SILENT: clean dirclean distclean symlinkclean config-clean download world help tmp/.packageinfo tmp/.targetinfo tmpinfo-clean tmp/.config-package.in tmp/.config-target.in .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package tmp/.prereq-target
 FORCE: ;