remove a hack that is no longer necessary
[openwrt/svn-archive/archive.git] / Makefile
index dbfdb8e82e6c23d693ed725bb0538087a31f7029..f4b153c17e2bb3bb11999874f898de6d497b49fc 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -141,17 +141,17 @@ clean: FORCE
 dirclean: clean
        rm -rf staging_dir_* toolchain_build_* tool_build
 
-distclean: dirclean config-clean symlinkclean docclean
+distclean: dirclean config-clean symlinkclean docs/clean
        rm -rf dl
 
 help:
        cat README
 
-doc:
-       $(MAKE) -C docs/ openwrt.pdf
+docs docs/compile: FORCE
+       $(MAKE) -C docs compile
 
-docclean:
-       $(MAKE) -C docs/ clean
+docs/clean: FORCE
+       $(MAKE) -C docs clean
 
 symlinkclean:
        -find package -type l | xargs rm -f