cleanup
[openwrt/svn-archive/archive.git] / Makefile
index 39ffb17fb5e770c8c6983feee5ef3568388665a2..facebe66b678124cef914d9b2ccc1e220bdab84d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -18,8 +18,13 @@ RELEASE:=Kamikaze
 all: world
 
 SHELL:=/usr/bin/env bash
 all: world
 
 SHELL:=/usr/bin/env bash
+export LC_ALL=C
+export LANG=C
 export TOPDIR=${shell pwd}
 include $(TOPDIR)/include/verbose.mk
 export TOPDIR=${shell pwd}
 include $(TOPDIR)/include/verbose.mk
+ifeq ($(KBUILD_VERBOSE),99)
+  MAKE:=3>/dev/null $(MAKE)
+endif
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
@@ -45,7 +50,7 @@ endif
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
-               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir || echo "ERROR: please fix $${dir}Makefile" >&2; \
+               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
        done > $@
 
 pkginfo-clean: FORCE
        done > $@
 
 pkginfo-clean: FORCE