Updated collectd to 4.4.4
[openwrt/svn-archive/archive.git] / XOrg / driver / xf86-video-vga / Makefile
index a67906db6115e3aaba4bd19c7b979b9511c6317b..2013a0634e34900136b96f1b582476ba8ad5c8eb 100644 (file)
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 
 PKG_BASE_NAME:=xf86
 PKG_NAME:=xf86-video-vga
-PKG_RELEASE:=1
-PKG_VERSION:=X11R7.1-4.1.0
-PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.2/src/driver
+PKG_RELEASE:=2
+PKG_VERSION:=4.1.0
+PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.3/src/driver
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
 
@@ -21,13 +21,13 @@ define Package/xf86-video-vga
   SECTION:=xorg-driver
   CATEGORY:=Xorg
   SUBMENU:=driver
-  DEPENDS:=+xorg-server  @TARGET_x86
+  DEPENDS:=+xorg-server  @DISPLAY_SUPPORT
   TITLE:=xf86-video-vga
   URL:=http://xorg.freedesktop.org/
 endef
 
 define Build/InstallDev
-       DESTDIR=$(1) $(MAKE) -C $(PKG_BUILD_DIR)/ $(MAKE_FLAGS) install
+       DESTDIR="$(1)" $(MAKE) -C $(PKG_BUILD_DIR)/ $(MAKE_FLAGS) install
 endef
 
 EXTRA_CPPFLAGS= -I$(STAGING_DIR)/usr/include/xorg \
@@ -46,7 +46,7 @@ define Build/Configure
        (cd $(PKG_BUILD_DIR)/$(CONFIGURE_PATH); \
        if [ -x $(CONFIGURE_CMD) ]; then \
                $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
-               $(foreach a,dri.h sarea.h dristruct.h exa.h,export ac_cv_file_$(call acvar,$(STAGING_DIR)/usr/include/xorg/$(a))=yes;) \
+               $(foreach a,dri.h sarea.h dristruct.h exa.h damage.h,export ac_cv_file_$(call acvar,$(STAGING_DIR)/usr/include/xorg/$(a))=yes;) \
                sed -i "s|sdkdir=.*|sdkdir=$(STAGING_DIR)/usr/include/xorg|g" $(PKG_BUILD_DIR)/configure ;\
                $(CONFIGURE_VARS) \
                $(CONFIGURE_CMD) \