Fix dependencies for a lot of xorg packages.
[openwrt/svn-archive/archive.git] / XOrg / lib / libSM / Makefile
index c6622ac06137c174dffd498c9f9ac4583dbba59e..44fefb40fc1c7479407c80c47e326be92aa2642b 100644 (file)
@@ -21,15 +21,11 @@ define Package/libSM
   SECTION:=xorg-libraries
   CATEGORY:=Xorg
   SUBMENU:=libraries
-  DEPENDS:=+xorg-headers-native +util-macros  +libICE @DISPLAY_SUPPORT
+  DEPENDS:=+xorg-headers-native +util-macros  +xproto +xtrans +libICE @DISPLAY_SUPPORT
   TITLE:=libSM
   URL:=http://xorg.freedesktop.org/
 endef
 
-define Build/InstallDev
-       DESTDIR=$(STAGING_DIR) $(MAKE) -C $(PKG_BUILD_DIR)/ $(MAKE_FLAGS) install
-endef
-
 ifeq (libSM,libX11)
  CONFIGURE_ARGS+=--without-xcb
 endif
@@ -71,7 +67,7 @@ define Package/libXaw/install
 endef
 
 define Build/InstallDev
-       $(CP) $(PKG_INSTALL_DIR)/* $(STAGING_DIR)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)
 endef
 
 $(eval $(call BuildPackage,libSM))