Fix dependencies for a lot of xorg packages.
[openwrt/svn-archive/archive.git] / XOrg / lib / libxkbfile / Makefile
index a376ea1040d2c353b18381e27bfa95bfbf00cd8e..604ab43424c518c43f09fceed718b532133bcedc 100644 (file)
@@ -21,15 +21,11 @@ define Package/libxkbfile
   SECTION:=xorg-libraries
   CATEGORY:=Xorg
   SUBMENU:=libraries
-  DEPENDS:=+xorg-headers-native +util-macros  @DISPLAY_SUPPORT
+  DEPENDS:=+xorg-headers-native +util-macros  +libX11 +kbproto @DISPLAY_SUPPORT
   TITLE:=libxkbfile
   URL:=http://xorg.freedesktop.org/
 endef
 
-define Build/InstallDev
-       DESTDIR=$(STAGING_DIR) $(MAKE) -C $(PKG_BUILD_DIR)/ $(MAKE_FLAGS) install
-endef
-
 ifeq (libxkbfile,libX11)
  CONFIGURE_ARGS+=--without-xcb
 endif
@@ -71,7 +67,7 @@ define Package/libXaw/install
 endef
 
 define Build/InstallDev
-       $(CP) $(PKG_INSTALL_DIR)/* $(STAGING_DIR)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)
 endef
 
 $(eval $(call BuildPackage,libxkbfile))