fix host binary installation of xine-lib
[openwrt/svn-archive/archive.git] / XOrg / lib / xine-lib / Makefile
index 6e05a362f4404121a886fdfea667d3f44cf06675..cc134fbd3e22dc06a38f34514f5d58cfaa8e50e1 100644 (file)
@@ -47,9 +47,11 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       $(CP) $(PKG_INSTALL_DIR)/* $(STAGING_DIR)/
-       $(SED) 's,-I$$$${prefix}/include,-I$(STAGING_DIR)/usr/include/,g' $(STAGING_DIR)/usr/bin/xine-config 
-       $(SED) 's,-L$$$${exec_prefix}/lib,-L$(STAGING_DIR)/usr/lib/,g' $(STAGING_DIR)/usr/bin/xine-config 
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+       $(SED) 's,-I$$$${prefix}/include,-I$(1)/usr/include/,g' $(1)/usr/bin/xine-config 
+       $(SED) 's,-L$$$${exec_prefix}/lib,-L$(1)/usr/lib/,g' $(1)/usr/bin/xine-config
+       $(INSTALL_DIR) $(2)/bin
+       mv $(1)/usr/bin/xine-config $(2)/bin
 endef
 
 define Package/xine-lib/install