even more compile fixes
[openwrt/svn-archive/archive.git] / XOrg / misc / x-bkgd-images / Makefile
index cb2a1e64fd3fb97280777987ddd788b086368493..18037181831ccea212c750ba0bc47bcb630e553f 100644 (file)
@@ -19,6 +19,7 @@ define Package/x-bkgd-images
   CATEGORY:=Xorg
   SUBMENU:=misc
   TITLE:=Background images for X
+  DEPENDS:=@DISPLAY_SUPPORT
 endef
 
 define Build/Configure
@@ -30,7 +31,8 @@ define Build/Compile
 endef
 
 define Package/x-bkgd-images/install
-       $(call pkg_install_files,`pwd`/files,$(1),/usr/share/X11/) 
+       $(INSTALL_DIR) $(1)
+       $(CP) ./files/* $(1)/ 
 endef
 
 $(eval $(call BuildPackage,x-bkgd-images))