Fix dependencies for a lot of xorg packages.
[openwrt/svn-archive/archive.git] / XOrg / proto / trapproto / Makefile
index 71cbe55e3c44bec267d84fcca52dca05eecfa704..82490ea924555d10e365d9b5f8f657febe68b086 100644 (file)
@@ -8,9 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=trapproto
-PKG_RELEASE:=1
-PKG_VERSION:=X11R7.0-3.4.3
-PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.2/src/proto/
+PKG_RELEASE:=2
+PKG_VERSION:=3.4.3
+PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.3/src/proto/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
 
@@ -20,13 +20,13 @@ define Package/trapproto
   SECTION:=xorg-proto
   CATEGORY:=Xorg
   SUBMENU:=proto
-  DEPENDS:= @TARGET_x86
+  DEPENDS:= @DISPLAY_SUPPORT
   TITLE:=trapproto
   URL:=http://xorg.freedesktop.org/
 endef
 
 define Build/InstallDev
-       DESTDIR=$(STAGING_DIR) $(MAKE) -C $(PKG_BUILD_DIR)/ $(MAKE_FLAGS) install
+       DESTDIR="$(1)" $(MAKE) -C $(PKG_BUILD_DIR)/ $(MAKE_FLAGS) install
 endef
 
 define Build/Compile