even more compile fixes
[openwrt/svn-archive/archive.git] / XOrg / server / xorg-server-X11R7.2 / Makefile
index ff22ccd10ebf582b8ada4702a08f3d511d4dc1ed..4b045f6910cd1c14608bedae152f97b13703c32b 100644 (file)
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=xorg-server-X11R7.2
+PKG_NAME:=xorg-server
 PKG_RELEASE:=1
-PKG_VERSION:=1.2.0
+PKG_VERSION:=X11R7.2-1.2.0
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.2/src/xserver/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/server/xorg-server-X11R7.2-$(PKG_VERSION)/
+PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/server/xorg-server-$(PKG_VERSION)/
 
 include $(INCLUDE_DIR)/package.mk
 
 EXTRA_CFLAGS+= -I${STAGING_DIR}/usr/include/X11/GL -I${STAGING_DIR}/usr/include/X11/dri/ -I${STAGING_DIR}/usr/include/X11/ -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
 
-CONFIGURE_VARS+=ac_cv_file__usr_share_sgml_X11_defs_ent=yes
+CONFIGURE_ARGS_KDRIVE=--enable-composite --enable-kdrive \
+               --disable-dga --disable-dri --disable-xinerama \
+               --disable-xf86misc --disable-xf86vidmode \
+               --disable-xorg --disable-xorgcfg \
+               --disable-xkb --disable-xnest --disable-xvfb \
+               --disable-xevie --disable-xprint --disable-xtrap \
+               --disable-dmx --disable-w100 \
+               --with-default-font-path=built-ins \
+               --enable-tslib --enable-xcalibrate 
+
+CONFIGURE_VARS+=ac_cv_file__usr_share_sgml_X11_defs_ent=yes 
+CONFIGURE_ARGS+=$(if $(CONFIG_XORG_BUILD_KDRIVE), $(CONFIGURE_ARGS_KDRIVE))
+
+DEPENDS_SERVER:=+calibrateproto \
+               +compositeproto \
+               +damageproto \
+               +fixesproto \
+               +recordproto \
+               +resourceproto \
+               +scrnsaverproto \
+               +videoproto \
+               +xextproto \
+               +xproto \
+               +libXext \
+               +libXdmcp \
+               +libXfont \
+               +libXrandr \
+               +xtrans \
+               +libX11 \
+               +glproto \
+               +xf86driproto \
+               +applewmproto \
+               +dmxproto \
+               +printproto \
+               +windowswmproto \
+               +xf86rushproto \
+               +xproxymanagementprotocol \
+               +libdrm \
+               +xf86miscproto \
+               +xf86vidmodeproto \
+               +xf86dgaproto \
+               +trapproto \
+               +xineramaproto \
+               +evieext \
+               +libxkbfile \
+               +libXt \
+               +libSM \
+               +libxkbui \
+               +libXxf86misc \
+               +libXxf86vm \
+               +libXaw \
+               +libXmu \
+               +libXpm \
+               +libnotimpl \
+               +Mesa \
+               @DISPLAY_SUPPORT
 
-define Package/xorg-server-X11R7.2/Default
+DEPENDS_KDRIVE:=+calibrateproto \
+               +compositeproto \
+               +damageproto \
+               +fixesproto \
+               +recordproto \
+               +resourceproto \
+               +scrnsaverproto \
+               +videoproto \
+               +xextproto \
+               +xproto \
+               +libXext \
+               +libXdmcp \
+               +libXfont \
+               +libXrandr \
+               +xtrans \
+               +libX11 \
+               @DISPLAY_SUPPORT 
+
+define Package/xorg-server/config
+       config XORG_BUILD_KDRIVE
+               bool "Build kdrive instead of xserver"
+               depends PACKAGE_xorg-server
+endef
+
+define Package/xorg-server/Default
   SECTION:=xorg-server
   CATEGORY:=Xorg
-  SUBMENU:=server
   URL:=http://xorg.freedesktop.org/
 endef
 
-define Package/xorg-server-X11R7.2
-$(call Package/xorg-server-X11R7.2/Default) 
+define Package/xorg-server
+$(call Package/xorg-server/Default) 
   TITLE:=Xorg server
-  DEPENDS:=+compositeproto-X11R7.1 \
-               +damageproto-X11R7.0 \
-               +fixesproto-X11R7.1 \
-               +recordproto-X11R7.0 \
-               +resourceproto-X11R7.0 \
-               +scrnsaverproto-X11R7.1 \
-               +videoproto-X11R7.0 \
-               +xextproto-X11R7.0 \
-               +xproto-X11R7.2 \
-               +libXext-X11R7.2 \
-               +libXdmcp-X11R7.2 \
-               +libXfont-X11R7.2 \
-               +libXrandr-X11R7.2 \
-               +xtrans-X11R7.2 \
-               +libX11-X11R7.2 \
-               +glproto-X11R7.2 \
-               +xf86driproto-X11R7.0 \
-               +applewmproto-X11R7.0 \
-               +dmxproto-X11R7.0 \
-               +printproto-X11R7.0 \
-               +windowswmproto-X11R7.0 \
-               +xf86rushproto-X11R7.0 \
-               +xproxymanagementprotocol-X11R7.0 \
-               +libdrm \
-               +xf86miscproto-X11R7.0 \
-               +xf86vidmodeproto-X11R7.0 \
-               +xf86dgaproto-X11R7.0 \
-               +trapproto-X11R7.0 \
-               +xineramaproto-X11R7.0 \
-               +evieext-X11R7.0 \
-               +libxkbfile-X11R7.2 \
-               +libXt-X11R7.2 \
-               +libSM-X11R7.2 \
-               +libxkbui-X11R7.1 \
-               +libXxf86misc-X11R7.1 \
-               +libXxf86vm-X11R7.1 \
-               +libXaw-X11R7.1 \
-               +libXmu-X11R7.2 \
-               +libXpm-X11R7.2 \
-               +libnotimpl \
-               +Mesa \
-               @TARGET_x86
   MENU:=1
+  DEPENDS:=$(if $(CONFIG_XORG_BUILD_KDRIVE), $(DEPENDS_KDRIVE), $(DEPENDS_SERVER))
 endef
 
-define Package/xorg-server-X11R7.2-config
-$(call Package/xorg-server-X11R7.2/Default) 
+define Package/xorg-server-config
+$(call Package/xorg-server/Default) 
   TITLE:=Xorg server configuration tools 
-  DEPENDS:=xorg-server-X11R7.2
+  DEPENDS:=xorg-server
 endef
 
 define Build/Configure
@@ -99,10 +136,10 @@ define Build/Compile
 
 endef
 
-define Package/xorg-server-X11R7.2/install
+define Package/xorg-server/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/Xorg $(1)/usr/bin/
-       cd $(1)/usr/bin; ln -s Xorg X
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/Xorg $(1)/usr/bin/
+       cd $(1)/usr/bin; ln -sf Xorg X
        $(INSTALL_DIR) $(1)/usr/share
        $(CP) $(PKG_INSTALL_DIR)/usr/share/* $(1)/usr/share/
        $(INSTALL_DIR) $(1)/usr/lib/xserver
@@ -118,15 +155,16 @@ define Package/xorg-server-X11R7.2/install
        $(CP) files/xorg.conf $(1)/etc/X11/
 endef
 
-define Packages/xorg-server-X11R7.2-config/install
+define Packages/xorg-server-config/install
        $(INSTALL_DIR) $(1)/usr/bin
-    $(CP) $(PKG_INSTALL_DIR)/usr/bin/xorgconfig $(1)/usr/bin/
+    $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xorgconfig $(1)/usr/bin/
 endef
 
 define Build/InstallDev
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(STAGING_DIR)/usr/include/
-       $(CP) $(PKG_BUILD_DIR)/xorg-server.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+       $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+       $(CP) $(PKG_BUILD_DIR)/xorg-server.pc $(1)/usr/lib/pkgconfig/
 endef
 
-$(eval $(call BuildPackage,xorg-server-X11R7.2))
-$(eval $(call BuildPackage,xorg-server-X11R7.2-config))
+$(eval $(call BuildPackage,xorg-server))
+$(eval $(call BuildPackage,xorg-server-config))