[packages] strace: call the install target, re-remove the obsolete 2.6.21 test, remov...
[openwrt/svn-archive/archive.git] / Xorg / app / eterm / Makefile
index 5cc06b4a8c3183d28392ddf0d8a59241cb99047f..5ffebc05eabd6680d23d24b9b96d06807c5a3bd5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -37,20 +37,16 @@ $(call Package/eterm/Default)
   DEPENDS:=eterm
 endef
 
-CONFIGURE_ARGS+=--with-imlib=$(STAGING_DIR)/usr/
+CONFIGURE_ARGS += \
+       --with-imlib=$(STAGING_DIR)/usr/
 
-define Build/Configure
-       cd  $(PKG_BUILD_DIR)/; $(TARGET_CONFIGURE_OPTS) $(CONFIGURE_VARS) \
-               $(CONFIGURE_CMD) \
-               $(CONFIGURE_ARGS_XTRA) \
-               $(CONFIGURE_ARGS) \
-               LIBS="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
-endef
+CONFIGURE_VARS += \
+       LIBS="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)\
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/lib/libiconv/include/" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib/libiconv/lib/"
+               CPPFLAGS="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/lib/libiconv/include/" \
+               LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib/libiconv/lib/"
        $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
 endef