[packages] quagga: Remove multipath caching policy patch since it is unsupported...
[openwrt/svn-archive/archive.git] / Xorg / app / gpxview / Makefile
index c8698f4d637f184eaff67d401d50096cee8f873d..94b5ba6487d714d11b7e53f202a190ef9f90e52e 100644 (file)
@@ -27,12 +27,13 @@ define Package/gpxview
   CATEGORY:=Xorg
   SUBMENU:=app
   TITLE:=GPXView Geocaching app
+  MAINTAINER:=Michael Buesch <mb@bu3sch.de>
   URL:=http://www.harbaum.org/till/maemo/index.shtml#gpxview
   DEPENDS:=+gpsd +libxml2 +libcurl +libsoup +gtkhtml +gtk2 +libintl +libiconv
 endef
 
 define Package/gpxview/description
-  GPXView is a viewer for Geocaching.com GPX files.
+  GPXView is a viewer for Geocaching.com GPX files and a simple GPS navigation software.
 endef
 
 EXTRA_CFLAGS:= \
@@ -45,13 +46,8 @@ EXTRA_LDFLAGS:= \
        -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
        -Wl,-rpath=/usr/lib/
 
-define Build/Install
-       $(MAKE_VARS) \
-       $(MAKE) -C $(PKG_BUILD_DIR)/$(MAKE_PATH) \
-               bindir="/bin" \
-               $(MAKE_INSTALL_FLAGS) \
-               install
-endef
+MAKE_INSTALL_FLAGS+= \
+       bindir="/bin"
 
 define Package/gpxview/install
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/share/gpxview