xf86-input-tslib: Update to 0.0.6. This fixes touchscreen on linux-2.6.37.
[openwrt/svn-archive/archive.git] / Xorg / driver / xf86-input-tslib / Makefile
index d7a8e4b3b7c646fe6baa438d448aff22dc607c13..9982245925922454c13541987886b575c8215e50 100644 (file)
@@ -1,26 +1,31 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xf86-input-tslib
-PKG_RELEASE:=1
-PKG_VERSION:=0.0.5
+PKG_VERSION:=0.0.6
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL:=http://www.pengutronix.de/software/xf86-input-tslib/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/$(PKG_NAME)-$(PKG_VERSION)/
-PKG_MD5SUM:=4231b517d216e9f80ba66f13a0f30afd
+PKG_MD5SUM:=b7a4d2f11637ee3fcf432e044b1d017f
+
 PKG_BUILD_DEPENDS:=randrproto inputproto xproto
+PKG_FIXUP:=libtool
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+ifeq ($(CONFIG_TARGET_s3c24xx),y)
+  TS_POINTERCAL=om_gta02
+endif
+
 define Package/xf86-input-tslib
   SECTION:=xorg-driver
   CATEGORY:=Xorg
@@ -31,10 +36,15 @@ define Package/xf86-input-tslib
 endef
 
 define Package/xf86-input-tslib/install
-       $(INSTALL_DIR) $(1)/usr/lib/xorg/modules/input
+       $(INSTALL_DIR) $(1)/usr/lib/xorg/modules/input $(1)/etc
        $(INSTALL_DATA) \
                $(PKG_INSTALL_DIR)/usr/lib/xorg/modules/input/tslib_drv.so \
                $(1)/usr/lib/xorg/modules/input/
+       $(if $(TS_POINTERCAL), \
+               $(INSTALL_DATA) \
+                       ./files/pointercal.$(TS_POINTERCAL) \
+                       $(1)/etc/pointercal \
+       )
 endef
 
 $(eval $(call BuildPackage,xf86-input-tslib))