[packages] xf86-video-glamo: don't depend on util-macros anymore
[openwrt/svn-archive/archive.git] / Xorg / driver / xf86-video-glamo / Makefile
index 61aacb86ed5b56be8fe3aaaf45fcd9c097e09868..f1b1bc7e16155247c95bc8ef07601f53f274067b 100644 (file)
@@ -7,9 +7,9 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=video-glamo
-PKG_VERSION:=20090504
-PKG_REV:=9491d818583114e429db1330dc5e07b4668dfa35
+PKG_NAME:=xf86-video-glamo
+PKG_VERSION:=20091029
+PKG_REV:=15954340b4b7aaf6ab850c149c2f75c1555d9360
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -19,8 +19,7 @@ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
 
 PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(PKG_NAME)-$(PKG_VERSION)/
-PKG_BUILD_DEPENDS:=xproto fontsproto randrproto renderproto videoproto \
-       util-macros
+PKG_BUILD_DEPENDS:=xproto fontsproto randrproto renderproto videoproto
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -31,7 +30,7 @@ define Package/xf86-video-glamo
   CATEGORY:=Xorg
   SUBMENU:=driver
   URL:=http://git.openmoko.org/?p=xf86-video-glamo.git
-  DEPENDS:=@DISPLAY_SUPPORT @arm||armeb +xserver-xorg
+  DEPENDS:=@DISPLAY_SUPPORT @arm||armeb @TARGET_s3c24xx +xserver-xorg
 endef
 
 define Package/xf86-video-glamo/description
@@ -42,6 +41,7 @@ define Build/Configure
        (cd $(PKG_BUILD_DIR) && autoreconf --force --install)
        $(call Build/Configure/Default, \
                --disable-jbt6k74-set-state \
+        --enable-engine-ioctls \
        )
 endef