[packages] gta1: Properly fix paths in gtk-config
[openwrt/svn-archive/archive.git] / Xorg / lib / gtk1 / Makefile
index 3b91d524c6ef96216a55265dec1463edb92a44c7..6feac6ed8b4c5a3db54ef4257a2631fc4a5da208 100644 (file)
@@ -5,13 +5,12 @@
 # See /LICENSE for more information.
 #
 # blogic@openwrt.org
-# $Id: Makefile 12578 2008-09-12 20:50:05Z lars $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gtk1
 PKG_VERSION:=1.2.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=gtk+-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNOME/gtk+/1.2/
@@ -31,7 +30,7 @@ CONFIGURE_ARGS_XTRA+=--x-includes=$(STAGING_DIR)/usr/include/ \
 
 EXTRA_CFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
 TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include
-EXTRA_LDFLAGS+=-lnotimpl -lglib -lgmodule
+EXTRA_LDFLAGS+=-lglib -lgmodule
 
 define Package/gtk1
   SECTION:=xorg-framework
@@ -47,6 +46,9 @@ define Build/InstallDev
        $(INSTALL_DIR) $(2)/bin
        mv $(1)/usr/bin/gtk-config $(2)/bin/
        $(SED) "s,libdirs=-L.*,libdirs=,g" $(2)/bin/gtk-config
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1="$(STAGING_DIR)/usr",g' \
+               $(2)/bin/gtk-config
 endef
 
 $(eval $(call BuildPackage,gtk1))