[packages] aodv-uu: resolve reference to CONFIG_LINUX_2_6
[openwrt/svn-archive/archive.git] / Xorg / lib / gtk1 / Makefile
index 3cce8a604c5f4d8a8a89a71e6cba803163b8d39e..70e331440ebe7c1972d3cd52e0e617db1c56ef24 100644 (file)
@@ -1,17 +1,16 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # blogic@openwrt.org
-# $Id: Makefile 12578 2008-09-12 20:50:05Z lars $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gtk1
 PKG_VERSION:=1.2.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=gtk+-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNOME/gtk+/1.2/
@@ -31,14 +30,15 @@ CONFIGURE_ARGS_XTRA+=--x-includes=$(STAGING_DIR)/usr/include/ \
 
 EXTRA_CFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
 TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include
-EXTRA_LDFLAGS+=-lnotimpl -lglib -lgmodule
+EXTRA_LDFLAGS+=-lglib -lgmodule
 
 define Package/gtk1
   SECTION:=xorg-framework
   CATEGORY:=Xorg
   SUBMENU:=framework
   TITLE:=GTK+ 1.2.10 package
-  DEPENDS:=+glib1 +libX11 +libXt +libnotimpl
+  DEPENDS:=+glib1 +libX11 +libXt
+  URL:=http://www.gtk.org/
 endef
 
 define Build/InstallDev
@@ -47,6 +47,9 @@ define Build/InstallDev
        $(INSTALL_DIR) $(2)/bin
        mv $(1)/usr/bin/gtk-config $(2)/bin/
        $(SED) "s,libdirs=-L.*,libdirs=,g" $(2)/bin/gtk-config
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1="$(STAGING_DIR)/usr",g' \
+               $(2)/bin/gtk-config
 endef
 
 $(eval $(call BuildPackage,gtk1))