add gtk2 fix by larsc
[openwrt/svn-archive/archive.git] / Xorg / lib / gtk2 / Makefile
index f03bf7c71475afff83602381534ad25199a21617..d144968956335b7bd87e2d5cd43b7c0a17e99212 100644 (file)
@@ -31,7 +31,7 @@ EXTRA_LDFLAGS+=\
        -L$(STAGING_DIR)/usr/lib/libiconv/lib/ \
        -L$(STAGING_DIR)/usr/lib/
 
-STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_gtk2 CONFIG_PACKAGE_gtk-cups2)
+STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_gtk2 CONFIG_PACKAGE_gtk2-cups)
 
 define Package/gtk2
   SECTION:=xorg-framework
@@ -60,7 +60,7 @@ define Build/Configure
                --disable-xinerama \
                --without-libjasper \
                --with-xinput \
-               $(if $(CONFIG_PACKAGE_gtk2-cups),--enable-cups,--disable-cups), \
+               $(if $(CONFIG_PACKAGE_gtk2-cups),--enable-cups=auto,--disable-cups), \
                gio_can_sniff=no \
        )
 endef