gtk2: we no longer need libgtk2.0-dev to be installed on the host
[openwrt/svn-archive/archive.git] / Xorg / lib / gtk2 / Makefile
index 2eaa87af89783a270f7633d8ed9edf18b22aaf88..e2dc0e093854372d636d3ab0b249e9a79ac0e2f5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -28,7 +28,7 @@ EXTRA_LDFLAGS+=\
        -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
        -L$(STAGING_DIR)/usr/lib/libintl/lib/ \
        -L$(STAGING_DIR)/usr/lib/libiconv/lib/ \
-       -L$(STAGING_DIR)/usr/lib/
+       $(TARGET_LDFLAGS)
 
 STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_gtk2 CONFIG_PACKAGE_gtk2-cups)
 
@@ -123,6 +123,4 @@ endef
 
 $(eval $(call BuildPackage,gtk2))
 $(eval $(call BuildPackage,gtk2-cups))
-$(eval $(call RequireCommand,gdk-pixbuf-csource, \
-       Please install gtk2.0-dev \
-))
+