gtk2: we no longer need libgtk2.0-dev to be installed on the host
[openwrt/svn-archive/archive.git] / Xorg / lib / gtk2 / Makefile
index f03bf7c71475afff83602381534ad25199a21617..e2dc0e093854372d636d3ab0b249e9a79ac0e2f5 100644 (file)
@@ -1,16 +1,15 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 12846 2008-10-03 22:38:55Z lars $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gtk2
 PKG_VERSION:=2.14.4
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=gtk+-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNOME/gtk+/2.14
@@ -29,9 +28,9 @@ EXTRA_LDFLAGS+=\
        -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
        -L$(STAGING_DIR)/usr/lib/libintl/lib/ \
        -L$(STAGING_DIR)/usr/lib/libiconv/lib/ \
-       -L$(STAGING_DIR)/usr/lib/
+       $(TARGET_LDFLAGS)
 
-STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_gtk2 CONFIG_PACKAGE_gtk-cups2)
+STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_gtk2 CONFIG_PACKAGE_gtk2-cups)
 
 define Package/gtk2
   SECTION:=xorg-framework
@@ -60,7 +59,7 @@ define Build/Configure
                --disable-xinerama \
                --without-libjasper \
                --with-xinput \
-               $(if $(CONFIG_PACKAGE_gtk2-cups),--enable-cups,--disable-cups), \
+               $(if $(CONFIG_PACKAGE_gtk2-cups),--enable-cups=auto,--disable-cups), \
                gio_can_sniff=no \
        )
 endef
@@ -70,7 +69,7 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/gtk-2.0/include/* $(1)/usr/include/
 
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} \
                $(1)/usr/lib/
 
@@ -86,7 +85,7 @@ define Package/gtk2/install
                $(1)/etc/gtk-2.0/
 
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/*.so* \
                $(1)/usr/lib/
 
@@ -124,6 +123,4 @@ endef
 
 $(eval $(call BuildPackage,gtk2))
 $(eval $(call BuildPackage,gtk2-cups))
-$(eval $(call RequireCommand,gdk-pixbuf-csource, \
-       Please install gtk2.0-dev \
-))
+