Cleanup xorg packages dependencies.
[openwrt/svn-archive/archive.git] / Xorg / lib / libXt / Makefile
index 79092a4fe26d3dac5c46fe3c8bc8f353b7a9ac6f..6fb26618f2f5876868f4e58e09df0f7cb1ae4814 100644 (file)
@@ -1,10 +1,11 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# blogic@openwrt.org 
+# blogic@openwrt.org
+
 include $(TOPDIR)/rules.mk
 
 PKG_BASE_NAME:=libXt
@@ -13,7 +14,8 @@ PKG_RELEASE:=2
 PKG_VERSION:=1.0.5
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.4/src/lib/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
+PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/$(PKG_NAME)-$(PKG_VERSION)/
+PKG_BUILD_DEPENDS:=xproto kbproto
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -21,7 +23,7 @@ define Package/libXt
   SECTION:=xorg-lib
   CATEGORY:=Xorg
   SUBMENU:=lib
-  DEPENDS:= +libSM +libX11 +xproto +kbproto @DISPLAY_SUPPORT
+  DEPENDS:=+libSM +libX11
   TITLE:=libXt
   URL:=http://xorg.freedesktop.org/
 endef