JavaScriptCore reqiures calling <make> before <make install>, otherwise it doesn...
[openwrt/svn-archive/archive.git] / Xorg / lib / qt4 / Makefile
index eb60a5e286e454855c048f56847ebedec214ccf1..14ce7ea75e55bc2e264ce7416ca289bfdf5a3bcc 100644 (file)
@@ -290,6 +290,8 @@ define Build/Configure
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
+       # just passing <make install> results in not building 3rdparty/webkit/JavaScriptCore
+       $(MAKE) -C $(PKG_BUILD_DIR)
        INSTALL_ROOT=$(PKG_INSTALL_DIR) \
                $(MAKE) -C $(PKG_BUILD_DIR) install
 endef
        INSTALL_ROOT=$(PKG_INSTALL_DIR) \
                $(MAKE) -C $(PKG_BUILD_DIR) install
 endef