qt4: update to version 4.7.0 beta2
[openwrt/svn-archive/archive.git] / Xorg / lib / qt4 / Makefile
index d074b4caaa29630a05e509e35965a5b4645b86bd..5cce57630f70613744b264e40addcb2c666d1298 100644 (file)
@@ -14,7 +14,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=qt4
-PKG_VERSION:=4.6.2
+PKG_VERSION:=4.7.0-beta2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=qt-everywhere-opensource-src-$(PKG_VERSION).tar.gz
@@ -34,12 +34,12 @@ endef
 
 define Package/qt4
   $(call Package/qt4/Default)
-  DEPENDS:=@FEATURE_drawing-backend_DirectFB +FEATURE_drawing-backend_DirectFB:DirectFB +zlib +libstdcpp +libsqlite3 # require directfb for now, as other systems (libX11, xcb) are untested
+  DEPENDS:=@FEATURE_drawing-backend_DirectFB +FEATURE_drawing-backend_DirectFB:directfb +zlib +libstdcpp +libsqlite3 # require directfb for now, as other systems (libX11, xcb) are untested
 endef
 
 define Package/qt4-gui
   $(call Package/qt4/Default)
-  #DEPENDS+=+FEATURE_drawing-backend_DirectFB:DirectFB +libpng +libtiff +libjpeg +libfreetype
+  #DEPENDS+=+FEATURE_drawing-backend_DirectFB:directfb +libpng +libtiff +libjpeg +libfreetype
   DEPENDS+=+libpng +libtiff +libjpeg +libfreetype
   TITLE+=(gui)
 endef
@@ -104,13 +104,13 @@ endef
 define Package/qt4-webkit
   $(call Package/qt4/Default)
   TITLE+=(webkit)
-  DEPENDS+=@USE_GLIBC||@USE_EGLIBC # until we do not have nptl-support within uclibc javascriptcore will fail to link against uclibc
+  DEPENDS+=@USE_GLIBC||@USE_EGLIBC||@UCLIBC_VERSION_0_9_32 # versions of uclibc prior 0.9.32 do not have nptl support
 endef
 
 define Package/qt4-script
   $(call Package/qt4/Default)
   TITLE+=(script)
-  DEPENDS+=@USE_GLIBC||@USE_EGLIBC # until we do not have nptl-support within uclibc, javascriptcore will fail to link against uclibc
+  DEPENDS+=@USE_GLIBC||@USE_EGLIBC||@UCLIBC_VERSION_0_9_32 # versions of uclibc prior 0.9.32 do not have nptl support
 endef
 
 define Package/qt4-scripttools
@@ -155,7 +155,13 @@ define Package/qt4-qt3support
   TITLE+=(qt3support)
 endef
 
-TARGET_CFLAGS+="-I$(STAGING_DIR)/usr/include/freetype2"
+define Package/qt4-declarative
+  $(call Package/qt4/Default)
+  TITLE+=(declarative)
+  DEPENDS+=+qt4-scripttools
+endef
+
+TARGET_CFLAGS+="-I$(STAGING_DIR)/usr/include/freetype2 -I$(PKG_BUILD_DIR)/include"
 
 define Build/Configure
        # demos/examples: which demos are going to be built depends on which features are going to to be compiled into qt
@@ -246,13 +252,14 @@ define Build/Configure
                        -$(if $(CONFIG_PACKAGE_qt4-phonon-backend),phonon-backend,no-phonon-backend) \
                        -svg \
                        -$(if $(CONFIG_PACKAGE_qt4-webkit),webkit,no-webkit) \
-                       -$(if $(CONFIG_PACKAGE_qt4-javascript-jit),javascript-jit,no-javascript-jit) \
+                       -no-javascript-jit \
                        -$(if $(CONFIG_PACKAGE_qt4-script),script,no-script) \
                        -$(if $(CONFIG_PACKAGE_qt4-scripttools),scripttools,no-scripttools) \
                        -$(if $(CONFIG_PACKAGE_qt4-accessibility),accessibility,no-accessibility) \
-                       -no-declarative \
+                       -$(if $(CONFIG_PACKAGE_qt4-declarative),declarative,no-declarative) \
                        -no-openssl \
                        -no-nis \
+                       $(if $(CONFIG_PACKAGE_qt4-gui),,-no-gui) \
                        -$(if $(CONFIG_PACKAGE_qt4-cups),cups,no-cups) \
                        -no-iconv \
                        -$(if $(CONFIG_PACKAGE_qt4-dbus),dbus,no-dbus) \
@@ -281,6 +288,8 @@ define Build/Configure
 endef
 
 define Build/Compile
+       # just passing <make install> results in not building 3rdparty/webkit/JavaScriptCore
+       $(MAKE) -C $(PKG_BUILD_DIR)
        INSTALL_ROOT=$(PKG_INSTALL_DIR) \
                $(MAKE) -C $(PKG_BUILD_DIR) install
 endef
@@ -527,6 +536,15 @@ define Package/qt4-qt3-support/install
        #       $(1)/usr/lib/Qt/plugins/
 endef
 
+define Package/qt4-declarative/install
+       $(INSTALL_DIR) \
+               $(1)/usr/lib
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libQtDeclarative.so* \
+               $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,qt4))
 $(eval $(call BuildPackage,qt4-gui))
 $(eval $(call BuildPackage,qt4-demos))
@@ -549,3 +567,4 @@ $(eval $(call BuildPackage,qt4-dbus))
 #$(eval $(call BuildPackage,qt4-gtkstyle))
 #$(eval $(call BuildPackage,qt4-glib))
 $(eval $(call BuildPackage,qt4-qt3support))
+$(eval $(call BuildPackage,qt4-declarative))