package qt4-declarative which is part of the new qt4.7 feature and language <QML>
[openwrt/svn-archive/archive.git] / Xorg / lib / qt4 / Makefile
index 61aafce7f8823dbeb1a30b2ba63b2e06060565a7..eb60a5e286e454855c048f56847ebedec214ccf1 100644 (file)
@@ -14,7 +14,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=qt4
-PKG_VERSION:=4.6.2
+PKG_VERSION:=4.7.0-beta1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=qt-everywhere-opensource-src-$(PKG_VERSION).tar.gz
@@ -34,12 +34,12 @@ endef
 
 define Package/qt4
   $(call Package/qt4/Default)
-  DEPENDS:=@FEATURE_drawing-backend_DirectFB +FEATURE_drawing-backend_DirectFB:DirectFB +zlib +libstdcpp +libsqlite3 # require directfb for now, as other systems (libX11, xcb) are untested
+  DEPENDS:=@FEATURE_drawing-backend_DirectFB +FEATURE_drawing-backend_DirectFB:directfb +zlib +libstdcpp +libsqlite3 # require directfb for now, as other systems (libX11, xcb) are untested
 endef
 
 define Package/qt4-gui
   $(call Package/qt4/Default)
-  #DEPENDS+=+FEATURE_drawing-backend_DirectFB:DirectFB +libpng +libtiff +libjpeg +libfreetype
+  #DEPENDS+=+FEATURE_drawing-backend_DirectFB:directfb +libpng +libtiff +libjpeg +libfreetype
   DEPENDS+=+libpng +libtiff +libjpeg +libfreetype
   TITLE+=(gui)
 endef
@@ -61,6 +61,18 @@ define Package/qt4-network
   TITLE+=(network)
 endef
 
+define Package/qt4-sqlite
+  $(call Package/qt4/Default)
+  TITLE+=(sqlite)
+  DEPENDS+=+libsqlite3
+endef
+
+define Package/qt4-mysql
+  $(call Package/qt4/Default)
+  TITLE+=(mysql)
+  DEPENDS+=+libmysqlclient
+endef
+
 #define Package/qt4-multimedia
 #  $(call Package/qt4/Default)
 #  TITLE+=(multimedia)
@@ -92,13 +104,13 @@ endef
 define Package/qt4-webkit
   $(call Package/qt4/Default)
   TITLE+=(webkit)
-  DEPENDS+=@USE_GLIBC||@USE_EGLIBC # until we do not have nptl-support within uclibc javascriptcore will fail to link against uclibc
+  DEPENDS+=@USE_GLIBC||@USE_EGLIBC||@UCLIBC_VERSION_0_9_32 # versions of uclibc prior 0.9.32 do not have nptl support
 endef
 
 define Package/qt4-script
   $(call Package/qt4/Default)
   TITLE+=(script)
-  DEPENDS+=@USE_GLIBC||@USE_EGLIBC # until we do not have nptl-support within uclibc, javascriptcore will fail to link against uclibc
+  DEPENDS+=@USE_GLIBC||@USE_EGLIBC||@UCLIBC_VERSION_0_9_32 # versions of uclibc prior 0.9.32 do not have nptl support
 endef
 
 define Package/qt4-scripttools
@@ -143,6 +155,12 @@ define Package/qt4-qt3support
   TITLE+=(qt3support)
 endef
 
+define Package/qt4-declarative
+  $(call Package/qt4/Default)
+  TITLE+=(declarative)
+  DEPENDS+=+qt4-scripttools
+endef
+
 TARGET_CFLAGS+="-I$(STAGING_DIR)/usr/include/freetype2"
 
 define Build/Configure
@@ -222,23 +240,28 @@ define Build/Configure
                        -system-libjpeg \
                        -system-freetype \
                        -system-sqlite \
+                       $(if $(CONFIG_PACKAGE_qt4-sqlite),-plugin-sql-sqlite,) \
+                       $(if $(CONFIG_PACKAGE_qt4-mysql),-plugin-sql-mysql,) \
                        -no-decoration-styled \
                        -no-decoration-windows \
                        -no-decoration-default \
                        -verbose \
                        -$(if $(CONFIG_PACKAGE_qt4-multimedia),multimedia,no-multimedia) \
                        -$(if $(CONFIG_PACKAGE_qt4-audio-backend),audio-backend,no-audio-backend) \
+                       -no-mediaservices \
+                       -no-media-backend \
                        -$(if $(CONFIG_PACKAGE_qt4-phonon),phonon,no-phonon) \
                        -$(if $(CONFIG_PACKAGE_qt4-phonon-backend),phonon-backend,no-phonon-backend) \
                        -svg \
                        -$(if $(CONFIG_PACKAGE_qt4-webkit),webkit,no-webkit) \
-                       -$(if $(CONFIG_PACKAGE_qt4-javascript-jit),javascript-jit,no-javascript-jit) \
+                       -no-javascript-jit \
                        -$(if $(CONFIG_PACKAGE_qt4-script),script,no-script) \
                        -$(if $(CONFIG_PACKAGE_qt4-scripttools),scripttools,no-scripttools) \
                        -$(if $(CONFIG_PACKAGE_qt4-accessibility),accessibility,no-accessibility) \
-                       -no-declarative \
+                       -$(if $(CONFIG_PACKAGE_qt4-declarative),declarative,no-declarative) \
                        -no-openssl \
                        -no-nis \
+                       $(if $(CONFIG_PACKAGE_qt4-gui),,-no-gui) \
                        -$(if $(CONFIG_PACKAGE_qt4-cups),cups,no-cups) \
                        -no-iconv \
                        -$(if $(CONFIG_PACKAGE_qt4-dbus),dbus,no-dbus) \
@@ -387,6 +410,32 @@ define Package/qt4-network/install
                $(1)/usr/lib/
 endef
 
+define Package/qt4-sqlite/install
+       $(INSTALL_DIR) \
+               $(1)/usr/lib/Qt/plugins/sqldrivers
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libQtSql.so* \
+               $(1)/usr/lib/
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/Qt/plugins/sqldrivers/libqsqlite.so \
+               $(1)/usr/lib/Qt/plugins/sqldrivers/
+endef
+
+define Package/qt4-mysql/install
+       $(INSTALL_DIR) \
+               $(1)/usr/lib/Qt/plugins/sqldrivers
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libQtSql.so* \
+               $(1)/usr/lib/
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/Qt/plugins/sqldrivers/libqsqlmysql.so \
+               $(1)/usr/lib/Qt/plugins/sqldrivers/
+endef
+
 #define Package/qt4-multimedia/install
 #      $(INSTALL_DIR) \
 #              $(1)/usr/bin
@@ -487,11 +536,22 @@ define Package/qt4-qt3-support/install
        #       $(1)/usr/lib/Qt/plugins/
 endef
 
+define Package/qt4-declarative/install
+       $(INSTALL_DIR) \
+               $(1)/usr/lib
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libQtDeclarative.so* \
+               $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,qt4))
 $(eval $(call BuildPackage,qt4-gui))
 $(eval $(call BuildPackage,qt4-demos))
 $(eval $(call BuildPackage,qt4-examples))
 $(eval $(call BuildPackage,qt4-network))
+$(eval $(call BuildPackage,qt4-sqlite))
+$(eval $(call BuildPackage,qt4-mysql))
 #$(eval $(call BuildPackage,qt4-multimedia))
 #$(eval $(call BuildPackage,qt4-audio-backend))
 $(eval $(call BuildPackage,qt4-phonon))
@@ -507,3 +567,4 @@ $(eval $(call BuildPackage,qt4-dbus))
 #$(eval $(call BuildPackage,qt4-gtkstyle))
 #$(eval $(call BuildPackage,qt4-glib))
 $(eval $(call BuildPackage,qt4-qt3support))
+$(eval $(call BuildPackage,qt4-declarative))