[packages/qt4] Qt-core does not depend on sqlite
[openwrt/svn-archive/archive.git] / Xorg / lib / qt4 / Makefile
index 160975f3b92c2e89d0eeb816af29b8cde677bd37..fd9dd1242c6484ce98dfa1c8eae8c86d7ef0bf3d 100644 (file)
@@ -12,8 +12,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=qt4
-PKG_VERSION:=4.7.0-beta2
+PKG_VERSION:=4.7.0
 PKG_RELEASE:=1
+PKG_MD5SUM:=3a2f25b9b115037277f4fb759194a7a5
 
 PKG_SOURCE:=qt-everywhere-opensource-src-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.qt.nokia.com/qt/source
@@ -31,9 +32,14 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_qt4-dbus \
        CONFIG_PACKAGE_qt4-phonon \
        CONFIG_PACKAGE_qt4-sqlite \
-       CONFIG_PACKAGE_qt4-mysql
+       CONFIG_PACKAGE_qt4-mysql \
+       CONFIG_PACKAGE_qt4-webkit \
+       CONFIG_PACKAGE_qt4-script \
+       CONFIG_PACKAGE_qt4-scriptools \
+       CONFIG_PACKAGE_qt4-openssl
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 -include $(if $(DUMP),,./files/qmake.mk)
 
 # this should be moved to a more generic place later, as other packages are configured different as well depending on available nptl support
@@ -57,17 +63,21 @@ define Package/qt4/Default
   SUBMENU:=framework
   TITLE:=qt4
   DEPENDS:=qt4
+  DEFAULT:=m if PACKAGE_qt4-gui && ALL
   URL:=http://qt.nokia.com/
 endef
 
 define Package/qt4
   $(call Package/qt4/Default)
-  DEPENDS:=+zlib +libstdcpp +libsqlite3
+  DEPENDS:=+zlib +libstdcpp
 endef
 
 define Package/qt4-gui
   $(call Package/qt4/Default)
-  DEPENDS+=+libpng +libtiff +libjpeg +libfreetype +qt4-network +FEATURE_drawing-backend_DirectFB:directfb +FEATURE_drawing-backend_libX11:libX11
+  DEFAULT:=
+  DEPENDS+=+libpng +libtiff +libjpeg +libfreetype +qt4-network \
+       +FEATURE_drawing-backend_libX11:libX11 \
+       +FEATURE_drawing-backend_libX11:libXext @DISPLAY_SUPPORT
   TITLE+=(gui)
 endef
 
@@ -100,6 +110,12 @@ define Package/qt4-mysql
   DEPENDS+=+libmysqlclient
 endef
 
+define Package/qt4-openssl
+  $(call Package/qt4/Default)
+  TITLE+=(openssl)
+  DEPENDS+=+libopenssl
+endef
+
 #define Package/qt4-multimedia
 #  $(call Package/qt4/Default)
 #  TITLE+=(multimedia)
@@ -213,7 +229,7 @@ endef
 define Package/qt4-drivers-mouse-tslibmousedriver
   $(call Package/qt4-drivers-mouse/Default)
   TITLE+=tslibmousedriver
-  DEPENDS:=+tslib
+  DEPENDS+=+tslib
 endef
 
 ###
@@ -234,6 +250,11 @@ define Package/qt4-drivers-gfx-linuxfb
   TITLE+=linuxfb
 endef
 
+define Package/qt4-drivers-gfx-vnc
+  $(call Package/qt4-drivers-gfx/Default)
+  TITLE+=VNC
+endef
+
 ###
 define Package/qt4-drivers-kbd/Default
   $(call Package/qt4/Default)
@@ -241,11 +262,6 @@ define Package/qt4-drivers-kbd/Default
   DEPENDS+=@QT4_WS_QWS
 endef
 
-define Package/qt4-drivers-kbd-linuxinput
-  $(call Package/qt4-drivers-kbd/Default)
-  TITLE+=linuxinput
-endef
-
 
 TARGET_INCDIRS+=$(STAGING_DIR)/include $(STAGING_DIR)/usr/include $(TOOLCHAIN_DIR)/include $(TOOLCHAIN_DIR)/usr/include
 TARGET_LIBDIRS+=$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib $(TOOLCHAIN_DIR)/lib $(TOOLCHAIN_DIR)/usr/lib
@@ -258,6 +274,11 @@ endif
 ifeq ($(CONFIG_QT4_WS_X11),y)
   FILEPFX:=x11-
 endif
+ifeq ($(CONFIG_PACKAGE_qt4-gui),)
+  # If GUI is disabled, we use the X11 prefix. That's good enough, for now.
+  # The X11 files also work for non-GUI.
+  FILEPFX:=x11-
+endif
 
 define Build/Configure
        # NOTES:
@@ -300,8 +321,7 @@ define Build/Configure
                        -nomake translations \
                        -xplatform $(QMAKE_PLATFORM_PREFIX)linux-openwrt-g++ \
                        -platform linux-g++ \
-                       $(if $(CONFIG_QT4_WS_QWS),-embedded) \
-                       $(if $(CONFIG_QT4_WS_X11),-x11) \
+                       $(if $(CONFIG_QT4_WS_X11),-x11,-embedded) \
                        -release \
                        -confirm-license \
                        -opensource \
@@ -326,16 +346,16 @@ define Build/Configure
                        $(if $(CONFIG_PACKAGE_qt4-phonon),-phonon,-no-phonon) \
                        -no-phonon-backend \
                        $(if $(CONFIG_PACKAGE_qt4-svg),-svg,-no-svg) \
-                       $(if $(NPTL),-webkit,-no-webkit) \
+                       $(if $(CONFIG_PACKAGE_qt4-webkit),-webkit,-no-webkit) \
                        -no-javascript-jit \
-                       $(if $(NPTL),-script,-no-script) \
-                       $(if $(NPTL),-scripttools,-no-scripttools) \
+                       $(if $(CONFIG_PACKAGE_qt4-script),-script,-no-script) \
+                       $(if $(CONFIG_PACKAGE_qt4-scripttools),-scripttools,-no-scripttools) \
                        -no-accessibility \
-                       $(if $(NPTL),-declarative,-no-declarative) \
-                       -no-openssl \
+                       $(if $(CONFIG_PACKAGE_qt4-declarative),-declarative,-no-declarative) \
+                       $(if $(CONFIG_PACKAGE_qt4-openssl),-openssl -I $(STAGING_DIR)/usr/include,-no-openssl) \
                        -no-nis \
                        -no-cups \
-                       -no-iconv \
+                       -iconv \
                        $(if $(CONFIG_PACKAGE_qt4-dbus),-dbus,-no-dbus) \
                        -no-gtkstyle \
                        -no-nas-sound \
@@ -349,7 +369,7 @@ define Build/Configure
                        -no-xfixes \
                        -no-xrandr \
                        -no-xrender \
-                       $(if $(CONFIG_QT4_WS_X11),-no-mitshm,-mitshm) \
+                       -no-mitshm \
                        $(if $(CONFIG_QT4_WS_X11),-no-fontconfig,-fontconfig) \
                        $(if $(CONFIG_QT4_WS_X11),-no-xinput,-xinput) \
                        $(if $(CONFIG_QT4_WS_X11),-no-xkb,-xkb) \
@@ -357,7 +377,7 @@ define Build/Configure
                        $(if $(CONFIG_PACKAGE_qt4-qt3support),-qt3support,-no-qt3support) \
                        -no-gfx-transformed \
                        -no-gfx-qvfb \
-                       -no-gfx-vnc \
+                       $(if $(CONFIG_PACKAGE_qt4-drivers-gfx-vnc),-plugin-gfx-vnc,-no-gfx-vnc) \
                        -no-gfx-multiscreen \
                        -no-gfx-qnx \
                        $(if $(CONFIG_PACKAGE_directfb),-plugin-gfx-directfb) \
@@ -371,7 +391,7 @@ define Build/Configure
                        -no-kbd-qvfb \
                        -no-kbd-qnx \
                        -qt-kbd-tty \
-                       -plugin-kbd-linuxinput \
+                       -qt-kbd-linuxinput \
        )
 endef
 
@@ -717,16 +737,16 @@ define Package/qt4-drivers-gfx-linuxfb/install
                $(1)/usr/lib/Qt/plugins/gfxdrivers/
 endef
 
-#  keyboard drivers
-define Package/qt4-drivers-kbd-linuxinput/install
+define Package/qt4-drivers-gfx-vnc/install
        $(INSTALL_DIR) \
-               $(1)/usr/lib/Qt/plugins/kbddrivers
+               $(1)/usr/lib/Qt/plugins/gfxdrivers
 
        $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/Qt/plugins/kbddrivers/libqlinuxinputkbddriver.so \
-               $(1)/usr/lib/Qt/plugins/kbddrivers/
+               $(PKG_INSTALL_DIR)/usr/lib/Qt/plugins/gfxdrivers/libqgfxvnc.so \
+               $(1)/usr/lib/Qt/plugins/gfxdrivers/
 endef
 
+#  keyboard drivers
 
 
 
@@ -737,6 +757,7 @@ $(eval $(call BuildPackage,qt4-examples))
 $(eval $(call BuildPackage,qt4-network))
 $(eval $(call BuildPackage,qt4-sqlite))
 $(eval $(call BuildPackage,qt4-mysql))
+$(eval $(call BuildPackage,qt4-openssl))
 #$(eval $(call BuildPackage,qt4-multimedia))
 #$(eval $(call BuildPackage,qt4-audio-backend))
 $(eval $(call BuildPackage,qt4-phonon))
@@ -761,5 +782,4 @@ $(eval $(call BuildPackage,qt4-drivers-mouse-tslibmousedriver))
 
 $(eval $(call BuildPackage,qt4-drivers-gfx-directfb))
 $(eval $(call BuildPackage,qt4-drivers-gfx-linuxfb))
-
-$(eval $(call BuildPackage,qt4-drivers-kbd-linuxinput))
+$(eval $(call BuildPackage,qt4-drivers-gfx-vnc))