[packages/qt4] Qt-core does not depend on sqlite
[openwrt/svn-archive/archive.git] / Xorg / lib / qt4 / Makefile
index f37d4b3c074846a8d9963dd68248a11b47a721cb..fd9dd1242c6484ce98dfa1c8eae8c86d7ef0bf3d 100644 (file)
@@ -33,9 +33,13 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_qt4-phonon \
        CONFIG_PACKAGE_qt4-sqlite \
        CONFIG_PACKAGE_qt4-mysql \
+       CONFIG_PACKAGE_qt4-webkit \
+       CONFIG_PACKAGE_qt4-script \
+       CONFIG_PACKAGE_qt4-scriptools \
        CONFIG_PACKAGE_qt4-openssl
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 -include $(if $(DUMP),,./files/qmake.mk)
 
 # this should be moved to a more generic place later, as other packages are configured different as well depending on available nptl support
@@ -65,14 +69,13 @@ endef
 
 define Package/qt4
   $(call Package/qt4/Default)
-  DEPENDS:=+zlib +libstdcpp +libsqlite3
+  DEPENDS:=+zlib +libstdcpp
 endef
 
 define Package/qt4-gui
   $(call Package/qt4/Default)
   DEFAULT:=
   DEPENDS+=+libpng +libtiff +libjpeg +libfreetype +qt4-network \
-       +FEATURE_drawing-backend_DirectFB:directfb \
        +FEATURE_drawing-backend_libX11:libX11 \
        +FEATURE_drawing-backend_libX11:libXext @DISPLAY_SUPPORT
   TITLE+=(gui)
@@ -247,6 +250,11 @@ define Package/qt4-drivers-gfx-linuxfb
   TITLE+=linuxfb
 endef
 
+define Package/qt4-drivers-gfx-vnc
+  $(call Package/qt4-drivers-gfx/Default)
+  TITLE+=VNC
+endef
+
 ###
 define Package/qt4-drivers-kbd/Default
   $(call Package/qt4/Default)
@@ -254,11 +262,6 @@ define Package/qt4-drivers-kbd/Default
   DEPENDS+=@QT4_WS_QWS
 endef
 
-define Package/qt4-drivers-kbd-linuxinput
-  $(call Package/qt4-drivers-kbd/Default)
-  TITLE+=linuxinput
-endef
-
 
 TARGET_INCDIRS+=$(STAGING_DIR)/include $(STAGING_DIR)/usr/include $(TOOLCHAIN_DIR)/include $(TOOLCHAIN_DIR)/usr/include
 TARGET_LIBDIRS+=$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib $(TOOLCHAIN_DIR)/lib $(TOOLCHAIN_DIR)/usr/lib
@@ -343,16 +346,16 @@ define Build/Configure
                        $(if $(CONFIG_PACKAGE_qt4-phonon),-phonon,-no-phonon) \
                        -no-phonon-backend \
                        $(if $(CONFIG_PACKAGE_qt4-svg),-svg,-no-svg) \
-                       $(if $(NPTL),-webkit,-no-webkit) \
+                       $(if $(CONFIG_PACKAGE_qt4-webkit),-webkit,-no-webkit) \
                        -no-javascript-jit \
-                       $(if $(NPTL),-script,-no-script) \
-                       $(if $(NPTL),-scripttools,-no-scripttools) \
+                       $(if $(CONFIG_PACKAGE_qt4-script),-script,-no-script) \
+                       $(if $(CONFIG_PACKAGE_qt4-scripttools),-scripttools,-no-scripttools) \
                        -no-accessibility \
-                       $(if $(NPTL),-declarative,-no-declarative) \
+                       $(if $(CONFIG_PACKAGE_qt4-declarative),-declarative,-no-declarative) \
                        $(if $(CONFIG_PACKAGE_qt4-openssl),-openssl -I $(STAGING_DIR)/usr/include,-no-openssl) \
                        -no-nis \
                        -no-cups \
-                       -no-iconv \
+                       -iconv \
                        $(if $(CONFIG_PACKAGE_qt4-dbus),-dbus,-no-dbus) \
                        -no-gtkstyle \
                        -no-nas-sound \
@@ -374,7 +377,7 @@ define Build/Configure
                        $(if $(CONFIG_PACKAGE_qt4-qt3support),-qt3support,-no-qt3support) \
                        -no-gfx-transformed \
                        -no-gfx-qvfb \
-                       -no-gfx-vnc \
+                       $(if $(CONFIG_PACKAGE_qt4-drivers-gfx-vnc),-plugin-gfx-vnc,-no-gfx-vnc) \
                        -no-gfx-multiscreen \
                        -no-gfx-qnx \
                        $(if $(CONFIG_PACKAGE_directfb),-plugin-gfx-directfb) \
@@ -388,7 +391,7 @@ define Build/Configure
                        -no-kbd-qvfb \
                        -no-kbd-qnx \
                        -qt-kbd-tty \
-                       -plugin-kbd-linuxinput \
+                       -qt-kbd-linuxinput \
        )
 endef
 
@@ -734,16 +737,16 @@ define Package/qt4-drivers-gfx-linuxfb/install
                $(1)/usr/lib/Qt/plugins/gfxdrivers/
 endef
 
-#  keyboard drivers
-define Package/qt4-drivers-kbd-linuxinput/install
+define Package/qt4-drivers-gfx-vnc/install
        $(INSTALL_DIR) \
-               $(1)/usr/lib/Qt/plugins/kbddrivers
+               $(1)/usr/lib/Qt/plugins/gfxdrivers
 
        $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/Qt/plugins/kbddrivers/libqlinuxinputkbddriver.so \
-               $(1)/usr/lib/Qt/plugins/kbddrivers/
+               $(PKG_INSTALL_DIR)/usr/lib/Qt/plugins/gfxdrivers/libqgfxvnc.so \
+               $(1)/usr/lib/Qt/plugins/gfxdrivers/
 endef
 
+#  keyboard drivers
 
 
 
@@ -779,5 +782,4 @@ $(eval $(call BuildPackage,qt4-drivers-mouse-tslibmousedriver))
 
 $(eval $(call BuildPackage,qt4-drivers-gfx-directfb))
 $(eval $(call BuildPackage,qt4-drivers-gfx-linuxfb))
-
-$(eval $(call BuildPackage,qt4-drivers-kbd-linuxinput))
+$(eval $(call BuildPackage,qt4-drivers-gfx-vnc))