add a new package for intltool (host only) to get rid of another prereq check
[openwrt/svn-archive/archive.git] / Xorg / lib / vte / Makefile
index 28f8e0ece54a754816c5813b8c3f6447bb7731f6..2e5f6dff793cbda3eda02f90c98a1795ffea5fcb 100644 (file)
@@ -1,22 +1,23 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 12808 2008-09-29 20:43:20Z lars $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vte
 PKG_VERSION:=0.17.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNOME/$(PKG_NAME)/0.17
 PKG_MD5SUM:=ec6cb2668db7146eae7cfc48af98f3ed
 PKG_FIXUP:=libtool
 
+PKG_BUILD_DEPENDS:=intltool/host
+
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
 
@@ -46,7 +47,7 @@ define Package/python-vte
   SUBMENU:=Python
   TITLE:=Python bindings for vte
   URL:=http://developer.gnome.org/arch/gnome/widgets/vte.html
-  DEPENDS:=python-core +PACKAGE_python-vte:python-gtk +vte
+  DEPENDS:=+python-mini +PACKAGE_python-vte:python-gtk +vte
 endef
 
 define Package/vte/description
@@ -70,7 +71,7 @@ define Build/InstallDev
                $(1)/usr/include/vte/
 
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/*.{so*,la,a} \
                $(1)/usr/lib
 
@@ -87,7 +88,7 @@ define Package/vte/install
                $(1)/usr/share/vte/termcap
 
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/*.so* \
                $(1)/usr/lib
 
@@ -99,7 +100,7 @@ endef
 
 define Package/python-vte/install
        $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)/gtk-2.0
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/gtk-2.0/*.so* \
                $(1)$(PYTHON_PKG_DIR)/gtk-2.0
 endef
@@ -107,4 +108,3 @@ endef
 $(eval $(call BuildPackage,vte))
 $(eval $(call BuildPackage,python-vte))
 
-