[packages] xcbproto: Don't install python files
[openwrt/svn-archive/archive.git] / Xorg / lib / xcbproto / Makefile
index f2d6aa19dbee4afd19c5b3dff00cb5cb3d868894..06afafb9ac6e7d49a73840283b28b47b2bd0bc30 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 12846 2008-10-03 22:38:55Z lars $
 
 include $(TOPDIR)/rules.mk
 
@@ -17,22 +16,33 @@ PKG_SOURCE_URL:=http://xcb.freedesktop.org/dist/
 PKG_MD5SUM:=d9275a714e83ab9c1f9b260c6eff1609
 PKG_INSTALL:=1
 
+#PKG_BUILD_DEPENDS:=python-mini/host
+
 include $(INCLUDE_DIR)/package.mk
+#$(call include_mk, python-package.mk)
+
+#STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,PACKAGE_python PACKAGE_python-mini)
 
 define Package/xcbproto
   SECTION:=xorg-libs
   CATEGORY:=Xorg
   SUBMENU:=libraries
+  BUILDONLY:=1
   TITLE:=xcbproto
 endef
 
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(INSTALL_DIR) $(1)/host/{lib/python2.5/site-packages/xcbgen,share/xcb}
+#define InstallPy
+#      $(INSTALL_DIR) $(1)/host/lib/$(PYTHON)/site-packages/xcbgen
+#      $(INSTALL_DATA) \
+#              $(PKG_INSTALL_DIR)/usr/lib/$(PYTHON)/site-packages/xcbgen/*.py \
+#              $(1)/host/lib/$(PYTHON)/site-packages/xcbgen/
+#endef
 
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/lib/python2.5/site-packages/xcbgen/*.py \
-               $(1)/host/lib/python2.5/site-packages/xcbgen/
+define Build/InstallDev
+#      $(call InstallPy,$(1),$(2))
+       $(INSTALL_DIR) \
+               $(1)/usr/lib/pkgconfig \
+               $(1)/host/share/xcb
 
        $(INSTALL_DATA) \
                $(PKG_INSTALL_DIR)/usr/share/xcb/* \
@@ -45,9 +55,4 @@ define Build/InstallDev
        $(SED) 's,datadir=/usr,datadir=$(STAGING_DIR)/host,g' $(1)/usr/lib/pkgconfig/xcb-proto.pc
 endef
 
-define Package/xcbproto/install
-       true
-endef
-
-
 $(eval $(call BuildPackage,xcbproto))